Añadir un bucle en Access - Automate_Studio - 20.3

Automatizar Studio con la ayuda online de Connect

Version
20.3
Language
Español (España)
Product name
Automate Studio
Title
Automatizar Studio con la ayuda online de Connect
First publish date
2018
ft:lastEdition
2024-01-18
ft:lastPublication
2024-01-18T15:25:12.203132

Cuando configure bucles para un archivo de datos de Access, haga lo siguiente:

  • Coloque todos los datos de encabezado en una tabla (principal).
  • Coloque todos los datos de posición relacionados con el encabezado en otra tabla dentro de la misma base de datos. Seleccione la tabla de posiciones cuando añada el bucle en el asignador.
  • Asegúrese de que las tablas de encabezados y de posiciones tengan un campo en común para que pueda vincular las posiciones al encabezado, y asegúrese también de que los valores del campo común sean los mismos en cada tabla.

Una vez las tablas estén unidas por el campo común, puede asignar los campos de posición. Para ello, no tiene más que arrastrar el campo desde el asignador hasta el panel Conjunto de datos y, a continuación, cambiar la dirección de asignación a Cargar en SAP.

Añadir el bucle

Antes de empezar, asegúrese de que la opción Permitir validación no esté activada. Si el botón está de color naranja, haga clic en él para desactivarla.

  1. Haga clic en la pestaña Asignar, luego en la pestaña Vista experto y, en el panel Conjunto de datos, haga clic en Añadir tabla.

    comando añadir tabla

  2. Escriba un nombre para la tabla (por ejemplo, Tabla2) y haga clic en Aceptar.

    Esta tabla contendrá los datos de posiciones. La tabla existente, la Tabla1, contendrá los datos del encabezado.

    para renombrar una tabla, haga clic con el botón secundario y luego haga clic en Renombrar. Una vez haya guardado el archivo de la base de datos, no podrá renombrar las tablas.

  3. Haga clic en la pestaña Tabla1 y, a continuación, en Añadir columna. Esta será la columna de combinación que asocie los datos en ambas tablas.

    comando añadir columna

  4. En el cuadro Nombre podrá escribir el nombre que desee darle a la columna. El nombre predeterminado es Campo.
  5. Haga clic en la flecha del cuadro Asignar a, haga clic en Ninguno y, a continuación, en Aceptar.
  6. Haga clic en la pestaña Tabla2, luego en Añadir columna (déle a esta columna de combinación el mismo nombre), haga clic en Nada en Asignar a cuadro y luego haga clic en Aceptar.
  7. En el asignador, seleccione las pantallas y los campos que incluyan la información de posiciones y haga clic en Crear bucle.

    comando crear bucle

  8. Haga clic en el cuadro Tabla maestra y luego en Tabla1.
  9. Haga clic en el cuadro Columna de identificador de bucle y luego en la columna de combinación.
  10. Haga clic en el cuadro Tabla de posiciones y, a continuación, en el nombre de la segunda tabla. Después haga clic en el cuadro Columna de identificador de bucle y luego en la columna de combinación.

    cuadro de diálogo del bucle

    Ahora aparecerá el mismo nombre de columna de combinación en los cuadros de las columnas del identificador de bucle de la tabla maestra y de la tabla de posiciones.

  11. Haga clic en Aceptar.

Asignar los campos

  1. En la pestaña Tabla1, arrastre el primer campo de encabezado a la tabla y, a continuación, cambie la dirección de asignación a Cargar en SAP. Repita la operación para todos los campos de encabezado que tenga.

    Arrastre el campo a la segunda fila de la tabla.

  2. Arrastre el campo Registro de ejecuciones a la tabla.
  3. Haga clic en Tabla2.
  4. Arrastre el campo que se haya asignado a Nada.
  5. Arrastre el primer campo de posición a la tabla y, a continuación, cambie la dirección de asignación a Cargar en SAP. Repita la operación para todos los campos de posición que tenga.
  6. Haga clic en la pestaña Archivo, a continuación, en Guardar y guarde ambos archivos.

Introducir los datos

  1. Haga clic en la pestaña Asignar, a continuación, haga clic en Iniciar Access e introduzca los datos en el archivo de la base de datos de Access.
  2. En la columna de combinación de la Tabla1, introduzca un identificador único para cada fila de encabezado. Por ejemplo, escriba 1 para la primera fila y 2 para la segunda.
  3. En la columna de combinación de la Tabla1, introduzca el identificador correspondiente de cada posición. Por ejemplo, escriba 1 en cada posición que esté asociada con el primer encabezado de la Tabla1.
  4. Una vez haya introducido los datos, guarde el archivo de datos y ciérrelo.
  5. En Studio, en el panel Conjunto de datos, haga clic en el icono de carpeta y abra el archivo de datos.

Cambiar el bucle

  • Haga clic en la etiqueta Bucle While o Fin de bucle para volver a abrir el cuadro Bucle.

Cortar, copiar y pegar el bucle

Seleccione y copie el bloque del bucle completo para pegarlo en cualquier parte del asignador.



Eliminar el bucle

  1. En el asignador, haga clic en la fila de inicio o la fila final del bucle para seleccionar la fila.
  2. Haga clic con el botón secundario en la fila y, a continuación, en Eliminar.