Starting the PRA - trillium_quality - 17.2

Trillium Director User Guide

Product type
Software
Product family
Trillium
Product
Trillium > Trillium Quality
Version
17.2
Language
English
Product name
Trillium Quality
Title
Trillium Director User Guide
Topic type
Overview
How Do I
Configuration
Reference
Installation
Administration
First publish date
2008
ft:lastEdition
2024-02-07
ft:lastPublication
2024-02-07T07:50:08.870306

To test cleansing or matching rules, start the PRA from the Director System Manager.

To start the PRA

  1. Open the Director System Manager (Start > Programs > Trillium Software > TSS 17 > Director System Manager (64-bit)). If the Director System Manager is located on the same machine as the Control Center, you can open it by clicking the Control Center’s Advanced tab and selecting Tools > Director System Manager.

    Note: If the Director System Manager’s Setup window opens, refer to Setting Up Hosts for information on host set up.
  2. On the Director System Manager’s Realtime View tab, right-click a cleanser or matcher server and select Launch Project Rule Analyzer. The Review or Override window opens.

  3. The host and port of the Director associated with the server from which you launched the PRA is displayed. To use a different Director, enter its host and port, or click Use Local Defaults to use the Director identified by the local system’s TRILLDIRADDR and TRILLDIRPORT environment variables. (If you do not know the Director’s port, you can use the Window’s system NETSTAT -b command to identify the Director’s port number.)

  4. The name of the cleanser or matcher from which you launched the PRA is displayed, as is a corresponding cleanser or matcher (one that uses the same project), if one exists. You can select Load all cleansers and matchers to have all of this Director’s active cleansers and matchers available for testing, or enter a specific cleanser and/or matcher to be tested. Note that loading all cleansers and matchers can significantly slow load time, depending on the size of your project.

  5. Click OK. The Project Rule Analyzer (PRA) opens. If you launched the PRA from a cleanser server, the Cleansing Rule Analyzer (CRA) tab is displayed, as shown in Figure: Cleansing Rule Analyzer Main Window. If you launched the PRA from a matching server, the Matching Rule Analyzer (MRA) tab is displayed, as shown in Figure: Reference Matching.

Note: If the text in this window is misaligned, ensure that your display is set to “Smaller - 100%” using the Control Panel > Appearance and Personalization > Display option.

The Director address and port is identified in the PRA’s title bar and the system identifier and server name of the cleanser or matcher server from which you launched the PRA is identified in the window. To change Directors or servers:

  • To change Directors, use File > Restart with a different Director.

  • To change servers, select a different server from the System/Server drop-down list, which will be populated if you chose the Load all cleansers and matchers option.