Modifying Field Lists - trillium_discovery - trillium_quality - 17.2

Trillium Relationship Linker Rules Editor

Product type
Software
Portfolio
Verify
Product family
Trillium
Product
Trillium > Trillium Discovery
Trillium > Trillium Quality
Version
17.2
Language
English
Product name
Trillium Quality and Discovery
Title
Trillium Relationship Linker Rules Editor
Topic type
Overview
How Do I
Configuration
Installation
Reference
Administration
First publish date
2016
ft:lastEdition
2024-07-01
ft:lastPublication
2024-07-01T08:52:01.213739

You can use the Field List Editor to add a rule to an existing Field List, delete a rule that is no longer needed, or change one or more values in a rule.

Note: The maximum number of matching rules is 50.
Note: If you insert a new row in the Field List Editor, a new column is automatically inserted into the Grade Pattern Editor. Conversely, if you delete a row in the Field List Editor, the corresponding column in the Grade Pattern Editor is also deleted.

Modify a rule

To modify a rule 

  1. Launch the Rules Editor and move to the Field List Editor window.
  2. Click the tab for the matching level you want to update. 
  3. Double-click the cell you want to change. See Reviewing Field Lists. Depending on the column, a text box opens so you can type a value or a list box appears so you can select a value. For the modifiers that require user input (for example, ARRAY1, DIFFER, DISTANCE, and LEVENSHTEIN), delete the cell value by selecting Delete Cell Value from the Edit menu and then double-click the cell to display the list of options.
  4. Repeat Step 2 for each cell you want to change.
  5. Choose Save from the File menu.

Add a rule

To add a rule

  1. Launch the Rules Editor and move to the Field List Editor window.
  2. Click the tab for the matching level you want to update. 
  3. Point to the row above or below where you want to insert the new rule.
  4. Choose the appropriate Insert Row option from the Edit menu.
  5. Double-click the first cell to open it for editing. See Reviewing Field Lists. Depending on the column, a text box opens so you can type a value, or a list box appears so you can select a value. If you are using multiple modifiers (for example, DISTANCE and LEVENSHTEIN), press the Ctrl key and select multiple modifiers from the list.
  6. Complete the rule definition by filling in the appropriate cells.  
    Note: The following fields are required: Description, Score A, Comparison Routine, and Field Name 1.
  7. Choose Save from the File menu.

Delete an existing rule

To delete an existing rule 

  1. Launch the Rules Editor and move to the Field List Editor window.
  2. Click the tab that contains the rule you want to delete.
  3. Right-click the row of the rule you want to delete.
  4. Choose Delete Row from the Edit menu. A notification message appears.
  5. Click Yes to proceed.
  6. Choose Save from the File menu.