Creating a Field List and Grade Pattern - trillium_discovery - trillium_quality - 17.2

Trillium Relationship Linker Rules Editor

Product type
Software
Portfolio
Verify
Product family
Trillium
Product
Trillium > Trillium Discovery
Trillium > Trillium Quality
Version
17.2
Language
English
Product name
Trillium Quality and Discovery
Title
Trillium Relationship Linker Rules Editor
Topic type
Overview
How Do I
Configuration
Installation
Reference
Administration
First publish date
2016
ft:lastEdition
2024-07-01
ft:lastPublication
2024-07-01T08:52:01.213739

Trillium is delivered with standard Field Lists and Grade Patterns for each country. You can modify those tables or create custom tables to define the matching rules you want the Relationship Linker to use.

Note:

The maximum number of matching attributes is 50.

To create a Field List and Grade Pattern

  1. Select New from the File menu. A blank Field List opens.
  2. Select DDL Select from the File menu and browse to the DDL file you want to apply.
  3. Double-click the first cell to open it for editing. Depending on the column, a text box opens so you can type a value or a list box appears so you can select a value.
  4. Complete the rule definition by filling in the appropriate fields.
    Note: The following fields are required: Description, Score A, Comparison Routine, and Field Name 1.
  5. Repeat Steps 3 and 4 for each matching rule. See Reviewing Field Lists for a description of each field.
  6. (Optional) Select General Comments from the Edit menu, enter comments in the General Comments window, and click OK. The comments will be visible when the file is generated.
  7. After all entries are complete, check for errors by selecting Error Report from the Tools menu.
  8. Select Save As... from the File menu.
  9. Enter a file name and click OK. The Setting Type window opens.
  10. Select the matching level for which you are creating the Field List and click OK. The options are:
    • Consumer Level 1 (household)
    • Consumer Level 2 (individual)
    • Business Level 1 (company)
    • Business Level 2 (contact)

    The Platform Save Option window opens.

  11. Select the line feed associated with the platform on which you are running and click OK.
  12. Select Generate Grade Pattern File from the Tools menu. Trillium creates a Grade Pattern File with columns that correspond to the rows you defined in the Field List table.
  13. Fill in the grades for each match level. See Reviewing Grade Patterns.
  14. Save the file when your edits are complete. Close the Rules Editor.
  15. Click Finish and run the Relationship Linker to test your changes. 
    Note: Any changes that are made will not be saved permanently until you click Finish in the main Relationship Linker window.