Servidor - spectrum_platform - 23.1

Guía de instalación de Spectrum para Linux

Product type
Portfolio
Integrate
Locate
Verify
Product family
Product
Spectrum > Spectrum Platform
Version
23.1
Language
Español (México)
Product name
Spectrum Technology Platform
Title
Guía de instalación de Spectrum para Linux
First publish date
2007
ft:lastEdition
2024-02-07
ft:lastPublication
2024-02-07T17:39:24.412268

Sistemas operativos

Sistema operativo compatible Notas
CentOS 7.x

Este sistema operativo requiere libpng12.so para las imágenes ráster MrSID.

Oracle Linux 7.x  
Oracle Linux 8.x  
Oracle Linux 9.x Este sistema operativo no admite las imágenes ráster MrSID.
Red Hat Enterprise Linux 7.x  
Red Hat Enterprise Linux 8.x  
Red Hat Enterprise Linux 9.x Este sistema operativo no admite las imágenes ráster MrSID.
Ubuntu 20.04 LTS

Este sistema operativo no admite las imágenes ráster MrSID.

Ubuntu 22.04 LTS Este sistema operativo no admite las imágenes ráster MrSID.

Sistemas operativos incompatibles, según el módulo

Los módulos específicos no son compatibles con los sistemas operativos Linux que se indican aquí.

Módulo Sistema operativo no compatible
Spectrum SAP Ubuntu 20.04 LTS, Ubuntu 22.04 LTS
Spectrum Universal Addressing

Ubuntu 20.04 LTS, Ubuntu 22.04 LTS

Espacio en disco

Nueva instalación Actualizar
  • El disco donde instalará Spectrum Technology Platform debe tener 4 GB de espacio libre para instalar todos los módulos o menos si se instalan menos módulos.
  • El disco donde se encuentra la carpeta "temp" debe tener al menos 10 GB de espacio libre para que el proceso de instalación pueda extraer los archivos necesarios. Podría requerir más según las opciones que pretenda instalar. De ser necesario, modifique la variable de entorno IATEMPDIR para utilizar esta ubicación con espacio suficiente.
  • Requisito de memoria para la actualización: debe tener un mínimo de 8  GB de RAM para ejecutar la actualización a la versión 2023.1.
  • El disco donde instalará Spectrum Technology Platform debe tener un espacio libre igual a tres veces el tamaño de la instalación actual. Para determinar el tamaño de la instalación actual, mira el tamaño de la carpeta en la que instaló Spectrum Technology Platform.
  • Si desea añadir módulos como parte de la actualización, necesitará 3 GB para instalar todos los módulos o menos si se va a instalar menos módulos.
  • El disco donde se encuentra la carpeta "temp" debe tener al menos 10 GB de espacio libre más cuatro veces el tamaño de la instalación actual. Por ejemplo, si la instalación actual es de 5 GB, necesitaría 30 GB de espacio en la carpeta "temp": (4 x 5 GB) + 10 GB = 30 GB. De ser necesario, modifique la variable de entorno IATEMPDIR para utilizar esta ubicación con espacio suficiente.
Nota: Si va a instalar un módulo que utiliza una base de datos de referencia, como una base de datos postal, una base de datos de geocodificación o tablas de normalización de datos, necesitará espacio para estos datos. El espacio total en disco varía según los módulos y bases de datos que está instalando.

Memoria

  • Requisito de aumento de memoria para actualización: debe tener un mínimo de 8 GB de RAM disponible para ejecutar la actualización.
  • Requisito básico de memoria: 16 GB
  • Data Normalization y Universal Name requieren memoria adicional si se usan estas bases de datos de nombres:
    • Paquete Plus para árabe: 5.5 GB
    • Paquete Plus para idiomas asiáticos - Chino: 32 MB
    • Paquete Plus para idiomas asiáticos - Japonés: 1.6 GB
    • Paquete Plus para idiomas asiáticos - Coreano: 8 MB
    • Nombres básicos: 1.1 GB

Versión de Java

  • SDK de Java 11 (64 bits)

Requisitos adicionales

  • Para todos los sistemas Linux, se requiere un valor mínimo para los descriptores de archivos. Consulte la versión actual de la Guía de instalación para ver la configuración recomendada. Esto se puede configurar mediante la ejecución del comando ulimit: ulimit –n limitsetting
    Nota: No configure ulimit como unlimited. Si lo hace, pueden producirse problemas en los recursos del sistema y las alertas de seguridad producirán una falla en la instalación.
  • Establezca el límite para tamaño de archivo en 2 GB. Para ajustar el límite del tamaño del archivo, utilice el comando: ulimit ulimit -f 4194304
  • En CentOS y Ubuntu, debe aumentar el número máximo de áreas del mapa de memoria. Para ello, abra el archivo /etc/sysctl.conf y establezca vm.max_map_count en 262144. Luego, reinicie el sistema y ejecute sysctl vm.max_map_count para verificar que la configuración se haya actualizado.

Requisitos del sistema para Global Geocoding

  • Los requisitos del sistema para Global Geocoding:
    • Mínimos: RAM de 16 GB, 4 CPU, almacenamiento de 100 GB
    • Recomendados: RAM de 32 GB, 8 CPU, almacenamiento de 200 GB suficiente para todos los conjuntos de datos.

La cantidad de memoria RAM dependerá de cuántos usuarios tenga en el sistema y de cuántos conjuntos de datos se carguen.

Para las actividades que usan Spark, que son Submit Spark Job y Spark Sorter:
  • Spark 2.0.1 o superior