Configuring a Linux Machine for MRR - spectrum_platform - 23 - 23.1

Spectrum Installation Guide for Linux

Product type
Software
Portfolio
Integrate
Locate
Verify
Product family
Spectrum
Product
Spectrum > Spectrum Platform
Version
23.1
Language
English
Product name
Spectrum Technology Platform
Title
Spectrum Installation Guide for Linux
Topic type
Installation
How Do I
Configuration
Overview
First publish date
2007
ft:lastEdition
2023-11-17
ft:lastPublication
2023-11-17T17:30:19.950257

To use MRR (Multi-Resolution Raster) files on Spectrum Spatial in a Linux environment, GCC and LIBC must be upgraded to the proper versions.

To configure a Linux machine for MRR:

  1. Install the UUID package, which installs LIBC.
    For example, to install the UUID package on CentOS 7, go to http://ftp.riken.jp/Linux and download the libuuid-devel-2.23.2-65.el7.x86_64.rpm file. You can start by visiting http://ftp.riken.jp/Linux, then select the relevant version from the list. For example, 7/, then choose the OS. Your final URL should look like, http://ftp.riken.jp/Linux/centos/7/os/x86_64/Packages/libuuid-devel-2.23.2-65.el7.x86_64.rpm. On a Linux machine do the following:
  2. Install devtoolset-3, which installs GCC v.4.9. For instructions, see https://www.softwarecollections.org/en/scls/rhscl/devtoolset-3/.
  3. Verify that GCC v.4.9 and LIBC v.2.17 (or later) are installed.
  4. Ensure that all the dependencies were resolved in the above steps. If any dependency is unresolved, install it and then repeat Step 2.
    Note: The above steps are applicable to CentOS version 7 only. If you are on a different operating system or version, the steps may vary. Follow the steps specific to your operating system and version. Refer to CentOS official download page for details.