Ajouter une boucle dans Access - Automate_Studio - Latest

Guide de l’utilisateur d’Automate Studio avec Studio Administrator

Product type
Logiciels
Portfolio
Integrate
Product family
Product
Automate > Automate Studio
Version
Latest
Language
Français
Product name
Automate Studio
Title
Guide de l’utilisateur d’Automate Studio avec Studio Administrator
Topic type
Installation
Aperçu
Comment faire
Administration
First publish date
2018
ft:lastEdition
2024-05-23
ft:lastPublication
2024-05-23T17:24:14.440011

Lorsque vous définissez des boucles pour un fichier de données Access, procédez comme suit :

  • Placez toutes les données d'en-tête dans une table (primaire).
  • Placez toutes les données de poste associées à l'en-tête dans une table distincte dans la même base de données. Sélectionnez la table de postes lorsque vous ajoutez la boucle dans le mappeur.
  • Vérifiez que les tables d’en-têtes et les tables de postes ont un champ commun pour pouvoir lier les postes à l’en-tête, et que les valeurs du champ commun sont identiques dans chaque table.

Après avoir joint toutes les tables par le champ commun, vous pouvez associer les champs de poste en les faisant glisser du mappeur vers le panneau Ensemble de données, puis en remplaçant la direction d'association par Envoyer à SAP.

Ajout de la boucle

Avant de commencer, veillez à désactiver Autoriser la validation. Si l’arrière-plan du bouton est orange, cliquez sur le bouton pour désactiver la fonction.

  1. Cliquez successivement sur les onglets Mapper et Vue Expert, puis dans le panneau Ensemble de données, cliquez sur Ajouter une table.

    Commande add table

  2. Saisissez le nom de la table, par exemple, Table2, puis cliquez sur OK.

    Cette table contiendra les données de poste. La table existante, Table1, contiendra les données d’en-tête.

    Pour renommer une table, cliquez dessus avec le bouton droit, puis cliquez sur Renommer. Après avoir enregistré le fichier de base de données, vous ne pouvez pas renommer les tables.

  3. Cliquez sur l’onglet Table1, puis sur Ajouter une colonne. La colonne devient la colonne de jointure qui associe les données dans les deux tables.

    Commande add column

  4. Dans la zone Nom, tapez le nom de la colonne. Le nom par défaut est Champ.
  5. Cliquez successivement sur la flèche dans la zone Associer à, sur Aucun et sur OK.
  6. Cliquez sur l’onglet de Table2, cliquez sur Ajouter une colonne, attribuez le même nom à la colonne de jointure, puis cliquez sur Aucun dans la zone Mapper à la zone et sur OK.
  7. Dans le mappeur, sélectionnez les écrans et les champs qui contiennent des informations de poste, puis cliquez sur Créer une boucle.

    Commande create loop

  8. Cliquez sur Table principale et sur Table1.
  9. Cliquez dans la zone Colonne d’identificateur de boucle et sur la colonne de jointure.
  10. Cliquez dans la zone Table Poste, puis sur le nom de la seconde table, Colonne d’identificateur de boucle et sur la colonne de jointure.

    boîte de dialogue boucle

    Maintenant, le même nom de colonne de jointure figure dans les zones Colonne d’identificateur de boucle de la table principale et de la table Poste.

  11. Cliquez sur OK.

Mappage des champs

  1. Dans l’onglet Table1, faites glisser le premier champ d’en-tête vers la table, puis remplacez la direction du mappage par Charger dans SAP. Recommencez l’opération pour les champs d’en-tête supplémentaires éventuels.

    Faites glisser le champ vers la deuxième ligne de la table.

  2. Faites glisser le champ RUN LOG vers la table.
  3. Cliquez sur Table2.
  4. Faites glisser le champ mappé à Aucun.
  5. Faites glisser le premier champ de poste vers la table, puis remplacez la direction du mappage par Charger dans SAP. Répétez les opérations pour d’autres champs de poste.
  6. Cliquez sur l’onglet Fichier et sur Enregistrer et enregistrez les deux fichiers.

Saisissez les données

  1. Cliquez sur l’onglet Mapper et sur Démarrer Access, puis entrez les données dans le fichier de base de données Access.
  2. Dans la colonne de jointure Table1, entrez un identificateur unique pour chaque ligne d’en-tête. Par exemple, saisissez 1 pour la première ligne, et 2 pour la seconde ligne.
  3. Dans la colonne de jointure Table2, entrez l’identificateur correspondant pour chacun des postes. Par exemple, saisissez 1 dans chaque ligne de poste associée à la première en-tête dans la Table1.
  4. Après avoir entré les données, enregistrez le fichier de données et fermez-le.
  5. Dans Studio, dans le panneau Ensemble de données, cliquez sur l'icône de dossier et ouvrez le fichier de données.

Changement de la boucle

  • Cliquez sur le libellé Boucle While ou Fin de boucle pour rouvrir la zone Boucle.

Couper, copier et coller la boucle

Sélectionnez et copiez le bloc de boucle complet et collez-le autre part dans le mappeur.



Supprimer la boucle

  1. Dans le mappeur, cliquez sur la ligne de début ou la ligne de fin de la boucle pour sélectionner la ligne.
  2. Cliquez avec le bouton droit de la souris sur la ligne et cliquez sur Supprimer.