Run settings for Transaction - Automate_Studio - Latest

Automate Studio with Evolve User Guide

Product type
Software
Portfolio
Integrate
Product family
Automate
Product
Automate > Automate Studio
Version
Latest
Language
English
Product name
Automate Studio
Title
Automate Studio with Evolve User Guide
Topic type
How Do I
Administration
Installation
Overview
First publish date
2018
ft:lastEdition
2024-06-13
ft:lastPublication
2024-06-13T14:35:52.915393

Some features are on the Run and Map tabs. Others are in the Options box.

Run tab settings

To lock a specified run setting so that it cannot be changed by a runner, click the padlock icon that is to the left. Settings that can be locked include the following:

  • Sheet
  • Start Row
  • End Row
  • Backup Data
  • Start SAP GUI
  • Skip Indicator

When running linked or cross-linked Transaction scripts (irrespective of the data source), if you set the AppOptions tag “SuppressPreRunWarning” to true, you will not receive the generic message dialogs with Run, Validate, Simulate, Debug, and Schedule actions. If however, the AppOptions tag "SuppressPreRunWarning" is set to false (the default setting) or if you do not have the AppOptions tag, you will receive the helpful generic dialog messages upon taking these actions. The generic message dialogs will not be displayed in Macro or Command Line runs.

(The AppOptions tag is not there by default in the AppOptions file; it must be manually added. And, "restore defaults" will remove the tag from the AppOptions file if a user has added it.)

Backup Data

Select this check box to automatically create a backup copy of the current SAP data fields (in a separate worksheet or Access database table) just before running the Transaction script. This setting is useful when you may want to roll back the data.

Note:

To use the Backup Data setting, you must record the Transaction script using Non-Batch Input mode.

If you select the Backup Data setting, pass a string "BACKUP_DATA" in the WinOptions table before you make the Automate Function Module call.

Start SAP GUI

If SAP requires screens to appear and you did not record the script in GUI Scripting mode, check the Start SAP GUI box to run in foreground mode without actually launching the SAP GUI.

The Start SAP GUI check box is for scripts that were recorded in Batch or Non-Batch modes.

Skip Indicator

Check the Skip Indicator box on the Run tab, and enter a symbol. Then enter that same symbol in fields that are empty in the data file. The indicator tells Studio not to upload the blank value from Excel and overwrite the data that is already in SAP.

Note:

If a field that is required to have data contains the skip indicator, the field will be skipped.

To remove custom symbols, click Restore Defaults, which will change all Studio options back to their original settings.

Save to Evolve

For files that do not require a review, the Run Settings group also includes the Save to Evolve option. Check this box to save those files to Evolve.

Note:

Only files run against production SAP systems will be saved.

Background Mode

To run the script in a separate instance of Excel, instead of running it inside Studio, check the Background Mode box. The script will run from Excel, although Excel will not open.

Be sure to run in background mode if your data file contains unsupported elements, such as PivotTables or charts.

Note:

The background mode setting is retained when you close and then later re-open the script.

Auto Logon Credentials

You can use saved credentials to automate your SAP logon when you run the script.

On the Run tab, click Auto Logon Credentials, and then click the credentials you want to use.

Specify this setting when you plan to schedule the script to run in the future or regularly so that SAP opens automatically. Even if you do not schedule the run, this setting is useful if you do not want to type your logon information each time you run the script.

Save auto logon credentials

  1. Click Auto Logon Credentials, and then click Add New Auto Logon Credentials.
  2. In the SAP Logon box, click the Credentials tab.
  3. Choose your SAP system, and then type your client number, user name, and password.
  4. Check the Save as auto logon credentials box, and type a name for the credentials in the Auto logon name box.

The credentials are saved in the wsSAPConnector.xml file, which is stored at C:\Users\<user name>\AppData\Roaming\Automate\Connector\11. If you connect to SAP from other computers, you can copy the file to them.

Extended logs

If the extended log has been turned on in the script, you can turn it off before you run the script by unchecking the Extended Log box on the Run Tab.

Run Error Rows and Unprocessed Rows in a single step

Check this box if you want Studio to run Error Rows and Unprocessed Rows in a single step.

Run Only Unprocessed Rows

Check this box to prevent Studio from processing records that have already been posted to SAP. When you set this option by checking the box, script runners will not be able to change the setting.

Upload Delay (ms)

This setting on the Run tab delays the calls to SAP between transactions by the number of milliseconds you specify. You can use it when running scripts that require a delay for commit code processing.

Map tab settings

Extended Log

The Extended Log option is on the Expert View tab in the Mapper. Just check the box in the Enable column.

Select this check box to see all the messages returned by SAP during the run of a transaction. These include warning messages and informational messages. Uncheck this box to see only the last message returned by SAP.

Note: The Extended Log feature is not available for scripts that were recorded in Batch Input mode or GUI Scripting mode.

Append Time stamp

In the Mapper, click the Log field and then check this box in the mapping properties to add the time of the run to the end of every log message returned from SAP during a run. The time stamp appears in the current regional settings of the computer where Studio is installed. This option is available for all data files, including BAPI scripts. Studio does not add timestamps during data validation.

Options box settings

Excel Save options

The options for saving an Excel data file are in the Options box, on the Data tab (File > Options > Data).

Do not save: The data file is not saved automatically after the run has finished.

Save at end of run: Studio automatically saves the data file at the end of each run.

Save after [n] records: Studio automatically saves the data file after it runs the specified number records (the default value is 10). You can change the number of records in the box that appears after you click the option.