Hinzufügen einer Schleife in Access - Automate_Studio - Latest

Automate Studio mit Evolve-Benutzerleitfaden

Product type
Software
Portfolio
Integrate
Product family
Product
Automate > Automate Studio
Version
Latest
Language
Deutsch
Product name
Automate Studio
Title
Automate Studio mit Evolve-Benutzerleitfaden
Topic type
Wie kann ich …
Installation
Übersicht
Administration
First publish date
2018
ft:lastEdition
2024-05-23
ft:lastPublication
2024-05-23T17:10:52.494368

Wenn Sie Schleifen für eine Access-Datendatei einrichten, gehen Sie folgendermaßen vor:

  • Platzieren Sie alle Kopfzeilendaten in eine (primäre) Tabelle.
  • Platzieren Sie sämtliche Positionsdaten, die sich auf diese Kopfzeile beziehen, in eine separate Tabelle in derselben Datenbank. Wählen Sie die Positionstabelle, wenn Sie die Schleife im Mapper hinzufügen.
  • Vergewissern Sie sich, dass die Kopf- und die Positionstabellen ein gemeinsames Feld haben, damit Sie die Positionen mit der Kopfzeile verknüpfen können. Stellen Sie außerdem sicher, dass die Werte des gemeinsamen Felds in jeder Tabelle identisch sind.

Wenn die Tabellen durch ein gemeinsames Feld verknüpft sind, können Sie die Positionsfelder zuordnen, indem Sie die Felder vom Mapper zum Datensatzbereich ziehen und dann die Zuordnungsrichtung zu „Zu SAP hochladen“ ändern.

Schleife hinzufügen

Stellen Sie sicher, bevor Sie beginnen, dass Validierung zulassen nicht aktiviert ist. Wenn die Hintergrundfarbe der Schaltfläche orange ist, klicken Sie die Schaltfläche an, um sie zu deaktivieren.

  1. Klicken Sie auf die Registerkarte Zuordnen, anschließend auf die Registerkarte Expertenansicht und dann im Bereich Datensatz auf Tabelle hinzufügen.

    Tabellenbefehl hinzufügen

  2. Geben Sie den Tabellennamen ein, zum Beispiel Tabelle2, und klicken Sie dann auf OK.

    Diese Tabelle wird die Positionsdaten enthalten. Die bestehende Tabelle, Tabelle1, beinhaltet die Kopfzeilendaten.

    Um eine Tabelle umzubenennen, klicken Sie mit der rechten Maustaste auf die Tabelle, und klicken Sie dann auf Umbenennen. Nachdem Sie die Datenbankdatei gespeichert haben, können Sie keine Tabellen mehr umbenennen.

  3. Klicken Sie auf die Registerkarte Tabelle1 und dann auf Spalte hinzufügen. Dies ist die Join-Spalte, die die Daten in den beiden Tabellen miteinander verbindet.

    Spaltenbefehl hinzufügen

  4. Im Namensfeld können Sie den Namen eingeben, den Sie der Spalte geben möchten. Der Standardname ist „Feld“.
  5. Klicken Sie auf den Pfeil im Kästchen Zuordnung zu, anschließend auf Keine und dann auf OK.
  6. Klicken Sie auf die Registerkarte für Tabelle2, klicken Sie dann auf Spalte hinzufügen, geben Sie dieser Join-Spalte den gleichen Namen, klicken Sie auf Keine im Kästchen Zuordnung zu und klicken Sie dann auf OK.
  7. Wählen Sie im Mapper die Bildschirme und Felder, welche die Positionsinformationen enthalten, und klicken Sie dann auf Schleife erstellen.

    Befehl „Schleife erstellen“

  8. Klicken Sie das Kästchen Mastertabelle an und klicken Sie auf Tabelle1.
  9. Klicken Sie das Kästchen Schleifenbezeichner-Spalte an und klicken Sie dann auf die Join-Spalte.
  10. Klicken Sie auf das Kästchen Positionstabelle, anschließend auf den Namen der zweiten Tabelle,dann auf die Schleifenbezeichner-Spalte und zuletzt auf die Join-Spalte.

    Schleifendialogfeld

    In den Kästchen „Schleifenbezeichner-Spalte“ für die Mastertabelle und die Positionstabelle erscheint nun der gleiche Join-Spaltenname.

  11. Klicken Sie auf OK.

Felder zuordnen

  1. Ziehen Sie auf der Registerkarte Tabelle1 das erste Kopfzeilenfeld zur Tabelle und ändern Sie dann die Zuordnungsrichtung zu Zu SAP hochladen. Wiederholen Sie den Vorgang für alle weiteren Kopfzeilenfelder.

    Ziehen Sie das Feld zur zweiten Zeile in der Tabelle.

  2. Ziehen Sie das Feld Protokoll ausführen in die Tabelle.
  3. Klicken Sie auf Tabelle2.
  4. Ziehen Sie das Feld, das zu „Keine“ zugeordnet wurde.
  5. Ziehen Sie das erste Kopfzeilenfeld in die Tabelle und ändern Sie dann die Zuordnungsrichtung zu Zu SAP hochladen. Wiederholen Sie den Vorgang für alle weiteren Positionsfelder.
  6. Klicken Sie auf die Registerkarte Datei, anschließend auf Speichern und speichern Sie beide Dateien.

Geben Sie die Daten ein.

  1. Klicken Sie auf die Registerkarte Zuordnen und klicken Sie dann auf Access starten, um die Daten in die Access-Datenbankdatei einzugeben.
  2. Geben Sie in der Join-Spalte von Tabelle1 einen eindeutigen Bezeichner für jede Kopfzeile ein. Geben Sie zum Beispiel „1“ für die erste Zeile und „2• für die zweite Zeile ein.
  3. Geben Sie in der Join-Spalte von Tabelle2 den entsprechenden Bezeichner für jede Position ein. Geben Sie zum Beispiel „1“ in jede Positionszeile ein, die mit der ersten Kopfzeile in Tabelle1 verbunden ist.
  4. Wenn Sie die Daten eingegeben haben, speichern Sie die Datendatei und schließen Sie sie.
  5. Klicken Sie in Studio im Bereich Datensatz auf das Ordnersymbol und öffnen Sie die Datendatei.

Ändern der Schleife

  • Klicken Sie auf Schleife While oder Schleife beenden, um das Kästchen Schleife zu öffnen.

Schleife ausschneiden, kopieren und einfügen

Wählen und kopieren Sie den kompletten Schleifenblock und fügen Sie ihn an einer anderen Stelle im Mapper ein.



Die Schleife löschen

  1. Im Mapper klicken Sie auf die Startzeile oder Endzeile der Schleife, um die Zeile auszuwählen.
  2. Führen Sie einen Rechtsklick auf die Zeile aus und klicken Sie dann auf Löschen.