Mise à niveau de Studio - Automate_Studio - 24.0

Guide d’installation et de mise à niveau d’Automate Studio avec Evolve

Product type
Logiciels
Portfolio
Integrate
Product family
Product
Automate > Automate Studio
Version
24.0
Language
Français
Product name
Automate Studio
Title
Guide d’installation et de mise à niveau d’Automate Studio avec Evolve
Copyright
2024
First publish date
2018
ft:lastEdition
2024-05-23
ft:lastPublication
2024-05-23T17:20:23.226570

Divers scénarios peuvent vous inviter à mettre à niveau vos clients Studio.

Si vous êtes un client existant de Studio avec Connect et que vous cherchez à effectuer une mise à niveau, lisez l’annonce d’annulation de production de Studio avec Connect.

Sur cette page, nous indiquons le meilleur chemin à suivre pour chacun des scénarios suivants :

Remarque : Ces chemins d’accès s’appliquent à Studio avec Automate Studio Administrator. Pour les scénarios Studio avec Evolve ou Studio avec Studio Manager, les chemins d’accès sont différents uniquement car la version d’Evolve/Studio Manager doit correspondre à la version de Studio dans tous les cas.

Il est supposé que vous suivrez les pratiques de mise à niveau standard. Par exemple, mettez toujours à jour vos environnements de développement/de test et passez aux systèmes d’assurance qualité et de production afin de minimiser l’impact des risques de mise à niveau. Il est également recommandé, dans les cas où vous n’êtes pas obligé de mettre à niveau le logiciel AFM au début, de le faire in fine afin de tirer pleinement parti de la nouvelle version de Studio.

Mise à jour de votre édition SAP ERP

Cela s’applique lorsque vous mettez à niveau votre version de base SAP de la version A à la version B (par exemple, mise à niveau vers SAP S/4HANA 1909). Consultez la configuration système requise pour Studio avant de prendre cette décision afin de vérifier qu’une version de Studio prend en charge l’édition SAP spécifique.

Meilleure pratique

  1. Mettez à niveau simultanément AFM et Studio vers la version testée avec cette version de SAP ERP.
  2. Importez vos scripts et effectuez des tests de régressions dessus, en les modifiant si nécessaire.
  3. Nous ne recevons pas d’accès préalable au logiciel SAP S/4HANA. Par conséquent, le processus de certification SAP peut durer plusieurs mois, une fois que SAP a publié sa version S/4HANA. La durée requise dépend de l’étendue de leurs modifications et de la nécessité d’inclure ou non d’autres modifications de composants logiciels tiers dans notre produit.

    Pour plus d’informations, voir Matrice de compatibilité ECC et S/4HANA du module de fonction Automate.

Option alternative prise en charge

  1. Contactez le service clientèle Automate pour savoir s’il existe des modifications connues requises dans Studio ou dans l’un de ses composants logiciels tiers résultant de cette version de SAP ERP. Si aucune n’est identifiée, vérifiez que la version de AFM testée par Automate avec la version de SAP est compatible avec votre version existante de Studio ou de Transaction, Query et Direct.
  2. Si elle est compatible, commencez par mettre à niveau votre AFM uniquement vers la version testée avec cette version de SAP.
  3. Démarrez les tests de régression de vos scripts existants dans votre environnement de test avec cette version de SAP. Si vous rencontrez des erreurs impossibles à résoudre, effectuez une mise à niveau vers la version de Studio qui correspond à la version AFM et importez vos scripts précédents pour déterminer si cela résout les erreurs.
  4. Si les erreurs persistent dans vos scripts, modifiez-les pour les mettre à jour afin d'éliminer les erreurs.
  5. Test de régression jugé nécessaire par votre entreprise.

Mise à niveau de SAP GUI

Cela s’applique lorsque vous mettez à niveau SAP GUI de la version A vers la version B. Consultez toujours la configuration système de Studio avant de prendre cette décision, afin de vous assurer qu’une version de Studio prend en charge cette édition de SAP GUI.

Meilleure pratique

  1. Mettez à niveau AFM et Studio vers la version testée avec cette version de SAP GUI.
  2. Importez vos scripts et effectuez des tests de régressions dessus, en les modifiant si nécessaire.

Option alternative prise en charge

  1. Consultez les notes d’éditionou contactez le service clientèle pour savoir si des modifications connues étaient nécessaires dans AFM suite à la qualification d’Automate de cette version de SAP GUI. Si aucune modification n’est identifiée, vérifiez que la version de Studio testée pour la compatibilité par Automate avec la version de SAP GUI est répertoriée comme étant compatible avec votre version de AFM.
  2. Si elle est compatible, commencez par mettre à niveau uniquement vos clients Studio vers la version testée avec SAP GUI.
  3. Démarrez les tests de régression de vos scripts existants dans votre environnement de test avec cette version de SAP GUI. Si vous rencontrez des erreurs impossibles à éliminer, effectuez une mise à niveau vers la version de AFM qui correspond à la version de Studio pour déterminer si cela permet d’éliminer les erreurs.
  4. Si les erreurs persistent dans vos scripts, modifiez-les pour les mettre à jour afin d’éliminer les erreurs.
  5. Test de régression jugé nécessaire par votre entreprise.

Mise à jour de Microsoft Office ou de votre système d’exploitation Microsoft

Cela s’applique lorsque vous mettez à jour vos versions d’Office ou de système d’exploitation et que l’installation actuelle de Studio ne prend pas en charge cette mise à jour. Par exemple, Office 2016 n’est pas pris en charge avec Automate version 10.7.

Meilleure pratique

  1. Utilisez la configuration système requise de Studio pour confirmer les versions des produits Microsoft prises en charge dans chaque version du produit Automate. Mettez à niveau Studio vers la dernière version prenant en charge la combinaison de la version Office ou de système d’exploitation prévue.
  2. Démarrez les tests de régression de vos scripts existants dans votre environnement de test avec cette version de système d’exploitation/Office.
  3. Si vous rencontrez des problèmes impossibles à résoudre, contactez le service clientèle d’Automate ou consultez les notes d’édition si ces problèmes ont une dépendance AFM. En cas de problèmes avec une dépendance AFM, mettez à niveau votre version de AFM à la version correspondant à Studio. Sinon, attendez qu’un correctif soit fourni pour résoudre le problème.
  4. Test de régression jugé nécessaire par votre entreprise.

Mise à jour basée sur la date de fin de vie de votre version de Studio ou sur l’accès aux nouvelles fonctionnalités de Studio

Ce scénario s’applique lorsque la date de fin de vie déclenche l’expiration de votre contrat de maintenance client, qui régit votre accès à le service clientèle Automate et votre droit de mise à niveau vers la dernière version de Studio sans frais supplémentaires.

Remarque : Si vous travaillez avec la version 10.x avec SAP GUI 710 et que vous mettez à jour les versions de Studio et de Microsoft Office parce qu'elles ne sont plus prises en charge, vous devez vous reporter à la section Mise à jour de votre SAP GUIci-dessus.

Toutefois, si vous utilisez 10.x sur Office 2013 et que vous devez désormais passer à la version 12.x ou 20.x, car l’ancienne version d’Automate n’est plus prise en charge, vous pouvez vous référer à cette section, car vous n’êtes pas obligé de mettre à niveau votre Office.

Meilleure pratique

  1. Mettez à niveau Studio vers la dernière version de GA disponible prise en charge par votre environnement actuel (voir la configuration système requise de Studio). Si l’environnement actuel n’est pas pris en charge, veuillez vous reporter aux sections sur les pratiques de mise à jour de SAP GUI, de la version SAP ou d’Office/du système d’exploitation.
  2. Démarrez les tests de régression de vos scripts existants dans votre environnement de test.
  3. Si vous rencontrez des problèmes impossibles à résoudre, contactez le service clientèle d’Automate ou consultez les notes d’édition si ces problèmes ont une dépendance AFM. En cas de problèmes avec une dépendance AFM, mettez à niveau votre version de AFM à la version correspondant à Studio. Sinon, attendez qu’un correctif soit fourni pour résoudre le problème.
  4. Test de régression jugé nécessaire par votre entreprise.