Présentation de l’interface utilisateur de Studio - Automate_Studio - 24.0

Guide d’installation et de mise à niveau d’Automate Studio avec Evolve

Product type
Logiciels
Portfolio
Integrate
Product family
Product
Automate > Automate Studio
Version
24.0
Language
Français
Product name
Automate Studio
Title
Guide d’installation et de mise à niveau d’Automate Studio avec Evolve
Copyright
2024
First publish date
2018
ft:lastEdition
2024-05-23
ft:lastPublication
2024-05-23T17:20:23.226570

Vous trouvez ci-dessous les commandes, les fonctions et les tâches communes dans Transaction et Query, ainsi que les options de Studio et leur emplacement dans Studio 20.3.

Pour rechercher rapidement une commande ou une fonction dans cette page, appuyez sur Ctrl+F.

  • Fichier, Vue, Associer et Exécuter font référence aux onglets du ruban dans la partie supérieur de la fenêtre de Studio.
  • Query dispose aussi des onglet Espace de travail et Critères.

Fichier

Fonctions Emplacement Studio 20.3

Nouveau

Fichier > Nouveau

Ouvrir

Fichier > Ouvrir

Enregistrer le script*

Fichier > Enregistrer

Barre d'outils d'accès rapide

Enregistrer sous*

Fichier > Enregistrer

Barre d'outils d'accès rapide

Quitter

Fichier > Quitter

*Pour enregistrer un script comme version précédente, cliquez sur la case Version et entrez la version à utiliser.

Aide

Fonctions

Emplacement Studio 20.3

Aide F1

Fichier > Aide > Aide de Studio

Générer des informations d'assistance

Fichier > Aide > Informations d'assistance

À propos de

Fichier > Aide

Indisponible Fichier > Aide > Notes d’édition

Transaction

Nouvel enregistrement

Fonctions Emplacement Studio 20.3

Créer un enregistrement en utilisant un code de transaction

Fichier > Nouveau > Transaction > Créer depuis un enregistrement

sélectionnez les champs dans un modèle Direct

Fichier > Nouveau > Direct > Créer depuis BAPI

Remarque :

les options dans la zone Changer le mode d’enregistrement varient selon que Automate Function Module est installé. Pour plus d'informations, consultez Modes d'enregistrement.

Fonctions

Emplacement Studio 20.3

Mode d'entrée batch

  1. Fichier > Nouveau > Transaction > Créer depuis un enregistrement
  2. Connectez-vous à SAP (si vous ne l'êtes pas déjà).
  3. Cliquez sur Changer.
  4. Sélectionnez le mode d'enregistrement dans la zone Changer le mode d'enregistrement.

Mode d'entrée non-batch (avec contrôles SAP)

  1. Fichier > Nouveau > Transaction > Créer depuis un enregistrement
  2. Connectez-vous à SAP (si vous ne l'êtes pas déjà).
  3. Cliquez sur Changer.
  4. Sélectionnez le mode d'enregistrement dans la zone Changer le mode d'enregistrement.

Mode d'entrée non-batch (sans contrôles SAP)

  1. Fichier > Nouveau > Transaction > Créer depuis un enregistrement
  2. Connectez-vous à SAP (si vous ne l'êtes pas déjà).
  3. Cliquez sur Changer.
  4. Sélectionnez le mode d'enregistrement dans la zone Changer le mode d'enregistrement.

Scriptage GUI

  1. Fichier > Nouveau > Transaction > Créer depuis un enregistrement
  2. Connectez-vous à SAP (si vous ne l'êtes pas déjà).
  3. Cliquez sur Changer.
  4. Sélectionnez le mode d'enregistrement dans la zone Changer le mode d'enregistrement.

Automate Function Module

  1. Fichier > Nouveau > Transaction > Créer depuis un enregistrement
  2. Connectez-vous à SAP (si vous ne l'êtes pas déjà).
  3. Cliquez sur Changer.
  4. Sélectionnez le mode d'enregistrement dans la zone Changer le mode d'enregistrement.

Récupérer les descriptions des champs en lecture seule/désactivés

  1. Fichier > Nouveau > Transaction > Créer depuis un enregistrement
  2. Connectez-vous à SAP (si vous ne l'êtes pas déjà).
  3. Récupérer les descriptions des champs en lecture seule/désactivés

Titre (champ modifiable)

  1. Fichier > Enregistrer.
  2. Fichier script > Titre du script.

Commentaires (champ modifiable)

  1. Fichier > Enregistrer.
  2. Fichier script > Commentaires du développeur.

Verrouiller un script Transaction

  1. Fichier > Enregistrer.
  2. Fichier script > Verrouiller le script.

Afficher des infos : version de Transaction

Fichier > Enregistrer > Fichier script > Version

Afficher des infos : Auteur, date de création

Fichier > Info

Raison de la création

Onglet Mapper > panneau Propriétés > Commentaires du développeur.

Changer le code de transaction d’un enregistrement existant Onglet Associer > Panneau Propriétés

Associer, Transaction

Fonctions Emplacement Studio 20.3

Mappage automatique

Associer > Association automatique

Vue de base du mappeur

Vue > Vue de base

Vue Expert du mappeur

Vue > Vue Expert

Activer/Désactiver une ligne

Mappeur > Activer la colonne

Mappeur > Clic droit sur le champ > Activer/Désactiver

Volet des propriétés > Champ activé

Type d'association

Mappeur > Association de colonne

Mappeur > Clic droit sur le champ > Direction d'association

Panneau des propriétés > Direction d'association

Associer > Bouton Direction d'association sur le ruban

Boucle + Appliquer feuille multiple

Associer > Créer une boucle

Description de champ, Nom de champ, Valeurs, les colonnes de remarques peuvent être modifiées

Changer une description/des valeurs en ligne

Changer une description/des valeurs depuis le panneau des propriétés

Ajouter des commentaires à des champs à la place de remarques :

  1. Clic droit > Insérer un commentaire
  2. Propriétés > Commentaires de l'auteur

Condition

Mapper > Créer une condition

Lire depuis SAP

Mappeur > Association de colonne > Télécharger depuis SAP

Mappeur > Clic droit sur le champ > Direction d'association > Télécharger depuis SAP

Panneau des propriétés > Direction d'association > Télécharger depuis SAP

Associer > bouton Direction d'association dans le ruban > Télécharger depuis SAP

Changer le type source

Mappeur > Panneau Ensemble de données

Association de colonne > Basée sur la colonne

  1. Fichier > Nouveau > Transaction > Créer depuis un enregistrement
  2. Connectez-vous à SAP (si vous ne l'êtes pas déjà).
  3. Type de donnée > Excel.

Association de colonne > Basée sur la cellule

Associer > Groupe d'association dans le ruban > Association basée sur la cellule

Désactiver/Activer la validation

Associer > Autoriser la validation

Filtre de mappeur (masquer tous les champs désactivés)

Vue > Champs désactivés

Filtre de mappeur (masquer les champs associés)

Vue > Champs associés

Filtre de mappeur (masquer les champs de valeur absolue)

Vue > Valeurs fixes

Filtre de mappeur (masquer les champs système (champs BDC)

Vue > Champs système

Rechercher dans le mappeur

Associer > Groupe d'association dans le ruban

Annuler la modification de mappeur

Associer > Annuler

Actualiser le mappeur

Associer > Groupe d'association dans le ruban

Synchroniser/Synchroniser tout

Associer > Groupe d'association dans le ruban

Couper, Copier, Coller des lignes

Associer > Couper/Copier et Coller

Cliquez avec le bouton droit sur une ligne et sur Couper ou Copier, puis cliquez avec le bouton droit sur une ligne et cliquez sur Coller.

Supprimer des lignes

Associer > Supprimer

Cliquez avec le bouton droit sur une ligne et cliquez sur Supprimer

Verrouiller les en-têtes

Associer > Verrouiller les en-tête

Écrire les en-têtes

Associer > Écrire les en-tête

Restaurer le mappage

Associer > Restaurer l'association

Aperçu Excel, aperçu Access

Fonction

Emplacement Studio 20.3

Icône

Ajouter une feuille (Excel)

Panneau Ensemble de données > Ajouter une feuille

ajouter une feuille

Ouvrir (Excel)

Panneau Ensemble de données > Ouvrir un fichier de données différent (bouton Ouvrir un dossier)

parcourir

Enregistrer (Excel)

Panneau Ensemble de données > Enregistrer le fichier d'ensemble de données en cours

bouton enregistrer

Ajouter une nouvelle table (Access)

Panneau Ensemble de données > Ajouter une table

ajouter une table

Ajoute une nouvelle colonne (Access)

Panneau Ensemble de données > Ajouter une colonne

ajouter une colonne

Changer une table (Access)

Panneau Ensemble de données > Cliquer sur le nom de la table

 

Ouvrir (Access)

Ouvrir un fichier d'ensemble de données différent

parcourir

Enregistrer (Access)

Panneau Ensemble de données > Enregistrer le fichier d'ensemble de données en cours

bouton enregistrer

Pièce jointe de do

Associer > Fonctions avancées

Propriétés Transaction

Les propriétés du script, les écrans et les champs se trouvent dans le ruban de l’onglet Mapper et dans le panneau Propriétés.

Fonctions

Emplacement Studio 20.3

Ignorer l'écran s'il est absent

Associer > Ignorer si absent

Mappeur > Colonne de description > icône

Panneau Propriétés > Ignorer si absent

Colonne de boucle

Panneau Propriétés > Colonne de boucle

Ignorer transaction si vide

Associer > Données requises

Mappeur > Colonne de valeur > icône

Panneau Propriétés > Données requises

Valider selon la liste

Associer > Valeurs autorisées

Mappeur > Colonne de valeur > icône

Panneau Propriétés > Valeurs autorisées

Écran d'exécution, Transaction

Fonctions

Emplacement Studio 20.3

Publier un script Transaction (dans un fichier Excel)

Exécuter > Groupe d'actions de script dans le ruban > Publier

Afficher les métadonnées d'un script

Fichier > Info

Ajouter un script aux favoris

Fichier > Ouvrir > Derniers scripts > Epingler cet élément

Choisir un fichier de données différent dans l'écran Exécuter (Parcourir)

Exécuter > Ouvrir un fichier de données différent (bouton Ouvrir un dossier au-dessus de la barre de statut jaune)

Ouvrir

Exécuter > Ouvrir le fichier de données dans Excel (au-dessus de la barre de statut jaune)

Écrire les en-têtes

Exécuter > Écrire les en-tête

Ligne de début, ligne de fin

Exécution

Nom de la feuille, nombre de lignes

Exécution

Colonne de journal, colonne du journal de validation (si la validation est activée)

Mappeur > Champ Journal d'exécution, Champ Journal de validation

Raisons de l'exécution

La boîte de dialogue s'ouvre sur Exécuter lorsque Raison de l'exécution requise est sélectionné.

Exécuter maintenant (options d’exécution)

Exécuter > Exécuter

Exécuter > Exécuter la plage définie

Exécuter > Exécuter les 5 premières lignes

Exécuter ultérieurement (options d’exécution)

Exécuter > Planifier

Exécuter en cas d’erreurs (options d’exécution)

Exécuter > Exécuter uniquement les lignes erronées

Exécution pas à pas - S'arrêter sur tous les écrans

Exécuter > Déboguer la plage définie

Exécuter > Déboguer uniquement la première ligne

Exécution pas à pas - S'arrêter en cas d'erreurs

Exécuter > Exécuter et arrêter en cas d'erreurs

Lancer IUG

Exécuter > Lancer IUG SAP

Valider

Exécuter > Valider

État d’avancement d’exécution dans la barre d’état

Barre d'avancement d'exécution sous le ruban

Arrêter

Arrêter (dans la barre d'avancement d'exécution sous le ruban)

Options d'exécution avancée

Fonctions

Emplacement Studio 20.3

Fermer l'application après l'exécution

Associer > Panneau Propriétés (propriétés du script)

Affectation de colonne de journal étendu

Mappeur > Champ Journal étendu

Ajouter l'horodatage au messages du journal SAP

Champ Journal > Propriétés > Ajouter l'horodatage

Indicateur de saut de champ

Exécuter > Indicateur de saut

Délai entre les transactions

Exécuter > Délai d'envoi

Lier un script Transaction

Exécuter > Chaîner les scripts

Fichier de connexion automatique

Exécuter > Informations d'identification de connexion automatique

Sauvegarde des données SAP

Exécuter > Sauvegarder les données

Exécution non publiée

Exécuter > Exécuter uniquement les lignes non traitées

Option d'enregistrement Excel

Fichier > Options > Paramètres de données

Visualiseur de journal > Graphiques, Exporter

Fichier > Visualiseur de journal

Planificateur (vue de base)

Fichier > Tâches planifiées

Planificateur (possibilité de planifier une exécution depuis l'assistant/page du planificateur)

Exécuter > Planifier

Contrôle d'autorisation

Fichier > Compte

Requête

Nouvelle requête

Fonctions

Emplacement Studio 20.3

Icône

Source de données : tables

Fichier > Nouveau > Requête > Créer depuis des tables

bouton de création depuis des tables

Source de données : InfoSets/requêtes

Fichier > Nouveau > Requête > Créer depuis un InfoSet

bouton de création depuis un infoset ou une requête

Source de données : bases de données logiques

Fichier > Nouveau > Requête > Créer depuis une base de données logiques

bouton de création depuis une base de données logique

Tables SAP et générateur de requête

espace de travail Query

Fonctions

Emplacement Studio 20.3

Arborescence Dictionnaire de données avec catégories

Espace de travail > Recherche de table > Dictionnaire de données

Restaurer le dictionnaire de données principal

Clic droit sur le niveau supérieur du dictionnaire de données

Options de catégorie de dictionnaire de données :

Ajouter une sous-catégorie

Renommer la catégorie

Supprimer la catégorie

Ajouter une table à une catégorie

Synchroniser

Clic droit sur une catégorie de dictionnaire de données

Options de table de dictionnaire de données :

Ajouter la table SAP à l'espace de travail

Supprimer la table

Clic droit sur une table de dictionnaire de données

Dictionnaire de données : recherche par table

Espace de travail > Recherche de table

Ajouter une table

Espace de travail > Ajouter une table

Supprimer la table

Espace de travail > Sélectionner la table > Supprimer la table

Inspecter la table

Espace de travail > Sélectionner la table > Inspecter la table

Afficher dans le dictionnaire de données

Espace de travail > Sélectionner la table > Afficher dans le dictionnaire de données

Ajout rapide de tables

Espace de travail > Zone Ajout rapide > Ajouter à l'espace de travail

Options de table :

Trier par description de champ

Trier par nom de champ

Trier par sélection de champ

Tri de champs par défaut

Clic droit sur la table dans l'espace de travail

Options de jointure

Espace de travail > Rechercher une table de jointure

Clic droit sur la jointure

Convertir la jointure

Espace de travail > Convertir la jointure

Supprimer la jointure

Espace de travail > Supprimer la jointure

Critères

Fonctions

Emplacement Studio 20.3

Volet Critères, Sortie

Espace de travail > Table > Case à cocher Sortie

Volet Critères, Sélection

Espace de travail > Table > Case à cocher Critères

Volet Critères, Description de champ

Espace de travail > Table > Nommer la description

Volet Critères, Type de sélection

Associer > Groupe de critères dans le ruban

Volet Critères, Clause Where

Critères

Volet Critères, Requis

Critères > Groupe de critères dans le ruban > Données requises

Associer, Requête

Fonctions

Emplacement Studio 20.3

Mappage automatique

Associer > Association automatique

Activer/Désactiver une ligne

Mappeur > Activer la colonne

Mappeur > Clic droit sur le champ > Activer/Désactiver

Volet des propriétés > Champ activé

Type d'association

Mappeur > Association de colonne

Mappeur > Clic droit sur le champ > Direction d'association

Panneau des propriétés > Direction d'association

Expression Excel

Cellule d'évaluation d'expression

Transformer le mappage original

Description d'évaluation d'expression

Valider

Associer > Sélectionner le champ dans le mappeur > Ajouter Transformation

Mappeur > Icône dans la colonne associée à la colonne

Panneau Propriétés > Icône de formule Transform

Aperçu de l'exécution

Associer > Aperçu d'exécution

Remarque : Seules les formules avec une syntaxe anglaise sont reconnues. Lorsqu’elles sont utilisées dans une feuille Excel pour l’allemand, le français ou l’espagnol, une erreur se produit.

Aperçu Excel, aperçu Access

Fonctions

Emplacement Studio 20.3

Icône

Ouvrir (Excel)

Panneau Ensemble de données > Ouvrir un fichier de données différent (bouton Ouvrir un dossier)

parcourir

Enregistrer (Excel)

Panneau Ensemble de données > Enregistrer le fichier d'ensemble de données en cours

bouton enregistrer

Propriétés et options de Query

Fonctions

Emplacement Studio 20.3

Zone Propriétés du script Query :

  • Titre
  • Système SAP
  • Créé par
  • Date et heure
  • Raison de la création
  • Commentaires

Associer > Panneau Propriétés

Zone Propriétés du script Query :

  • Verrouiller le script Query
  • Mot de passe
Fichier > Enregistrer**

**Pour enregistrer un script comme version précédente, cliquez sur la zone Version et entrez la version à utiliser.

Écran Exécuter, Query

Fonctions

Emplacement Studio 20.3

Publier

Exécuter > Publier

Écrire les en-têtes

Exécuter > Écrire les en-tête

Ligne de début

Exécution

Nom de la feuille, nombre de lignes

Exécution

Raison de l'exécution

La boîte de dialogue s'ouvre sur Exécuter lorsque Raison de l'exécution requise est sélectionné.

Exécuter maintenant

Exécuter > Exécuter

Exécuter > Exécuter la plage définie

Exécuter > Exécuter les 5 premières lignes

Exécuter plus tard

Exécuter > Planifier

Mode arrière-plan

Exécuter > Démarrer le mode en arrière-plan

Exécuter comme processus SAP en arrière-plan

Exécuter > Exécuter comme processus SAP en arrière-plan

Adaptive Query Throttling

Exécuter > Activer la régulation Query adaptative

Nombre d'entrées

Exécuter > Nombre d'entrées

Outils > Options

Pour plus d’informations, voir options Studio.

Paramètres par défaut de l’application

Fonctions

Emplacement Studio 20.3

Paramètres par défaut de chemin

Fichiers > Options > Emplacements

Paramètres par défaut de Microsoft Excel

Fichiers > Options > Données

Colonne de journal Vous pouvez choisir entre la première colonne et la dernière colonne ou définir une colonne dans l’outil de mappage
Utiliser une feuille de calcul Excel dans,l’aperçu de l'outil de mappage Studio 20.3 affiche la feuille Excel en mode Spreadsheet Gear
Exécuter Excel en arrière-plan Studio 20.3 exécute Excel en arrière-plan, mais ne lance pas Excel.

Préférence de lecture des données

Fichiers > Options > Données

Nombre de lignes devant rester vides avant l'arrêt de l'exécution

Fichiers > Options > Données

Nombre d'enregistrements par défaut dans les catégories Récent et Favori :

Fichier > Options > Paramètres de données

Indicateur de saut de champ

Fichiers > Options > Données

Tronquer les données avant de les envoyer au système SAP

Fichiers > Options > Données

Nombre par défaut d'enregistrements à télécharger Fichiers > Options > Données

Paramètres par défaut SAP

Fonctions

Emplacement Studio 20.3

Paramètres de connexion par défaut

Fichier > Options > Paramètres SAP

Paramètres par défaut d'enregistrement

Fichier > Options > Paramètres SAP

Autoriser le lancement de SAP GUI en mode multithread

Fichier > Options > Paramètres SAP

Formats des données utilisateur Fichiers > Options > Données

Gestion des erreurs

Fonctions

Emplacement Studio 20.3

Pour Excel

Commun à tous les fichiers de données : Fichier > Options > Journaux et erreurs

Pour Access

Commun à tous les fichiers de données : Fichier > Options > Journaux et erreurs

Trace (Application, SAP)

Fichier > Options > Journaux et erreurs

Autres options

Fonctions

Emplacement Studio 20.3

Gestion d'ALF

Boîte de dialogue de connexion avancée à SAP

Avertissement du serveur de production

Fichier > Options > Avertissement du serveur de production

Paramètres de connexion du client

Fichier > Options > Proxy et e-mail

Détails du journal d'en-tête

Fichier > Options > Journaux et erreurs

Rétablir les valeurs par défaut

Fichier > Options

Commandes et fonctions diverses

Fonctions

Emplacement Studio 20.3

Changer la langue depuis la barre d'état

Fichier > Aide > Liste des langues

Informations de connexion au serveur SAP dans la barre d'état

Barre de statut

Message de bienvenue de l’utilisateur connecté

Barre de statut

Icône En ligne/Hors ligne dans la barre d'état

Nom de l'utilisateur connecté dans la barre d'état