Información general sobre la interfaz de usuario de Studio - Automate_Studio - 24.0

Guía de instalación y actualización de Automate Studio con Studio Administrator

Product type
Software
Portfolio
Integrate
Product family
Product
Automate > Automate Studio
Version
24.0
Language
Español (España)
Product name
Automate Studio
Title
Guía de instalación y actualización de Automate Studio con Studio Administrator
Copyright
2024
First publish date
2018
ft:lastEdition
2024-05-23
ft:lastPublication
2024-05-23T17:14:30.740617

A continuación se indican algunos comandos, funciones y tareas habituales de Transaction y Query, además de las opciones de Studio y dónde puede encontrarlo todo en Studio 20.3.

Para encontrar un comando o una función rápidamente en esta página, pulse Ctrl+F.

  • Archivo, Ver, Asignar y Ejecutar hacen referencia a las pestañas de la cinta en la parte superior de la ventana de Studio.
  • Query también tiene las pestañas Área de trabajo y Criterios.

Archivo

Funciones Ubicación en Studio 20.3

Nuevo/a

Archivo > Nuevo

Abrir

Archivo > Abrir

Guardar script*

Archivo > Guardar

Barra de herramientas de acceso rápido

Guardar como*

Archivo > Guardar

Barra de herramientas de acceso rápido

Salir

Archivo > Salir

*Para guardar un script en una versión anterior, haga clic en el cuadro Versión y elija la versión que desee.

Ayuda

Funciones

Ubicación en Studio 20.3

Ayuda F1

Archivo > Ayuda > Ayuda de Studio

Generar información de soporte técnico

Archivo > Ayuda > Información de soporte técnico

Acerca de

Archivo > Ayuda

No disponible Archivo > Ayuda > Notas de la versión

Transacción

Nueva grabación

Funciones Ubicación en Studio 20.3

Crear una grabación con un código de transacción

Archivo > Nuevo > Transaction > Crear desde grabación de SAP

Seleccionar campos de una plantilla de Direct

Archivo > Nuevo > Direct > Crear desde BAPI

Nota:

Las opciones en el cuadro Cambiar modo de grabación pueden variar dependiendo de si está instalado Automate Function Module. Consulte Modos de grabación si desea obtener más información.

Funciones

Ubicación en Studio 20.3

Modo de entrada por lotes

  1. Archivo > Nuevo > Transaction > Crear desde grabación de SAP.
  2. Inicie sesión en SAP (si aún no lo ha hecho).
  3. Haga clic en Cambiar.
  4. Seleccione el modo de grabación en el cuadro Cambiar modo de grabación.

Modo de entrada que no sea por lotes (con controles de SAP)

  1. Archivo > Nuevo > Transaction > Crear desde grabación de SAP.
  2. Inicie sesión en SAP (si aún no lo ha hecho).
  3. Haga clic en Cambiar.
  4. Seleccione el modo de grabación en el cuadro Cambiar modo de grabación.

Modo de entrada que no sea por lotes (sin controles de SAP)

  1. Archivo > Nuevo > Transaction > Crear desde grabación de SAP.
  2. Inicie sesión en SAP (si aún no lo ha hecho).
  3. Haga clic en Cambiar.
  4. Seleccione el modo de grabación en el cuadro Cambiar modo de grabación.

GUI Scripting

  1. Archivo > Nuevo > Transaction > Crear desde grabación de SAP.
  2. Inicie sesión en SAP (si aún no lo ha hecho).
  3. Haga clic en Cambiar.
  4. Seleccione el modo de grabación en el cuadro Cambiar modo de grabación.

Automate Function Module

  1. Archivo > Nuevo > Transaction > Crear desde grabación de SAP.
  2. Inicie sesión en SAP (si aún no lo ha hecho).
  3. Haga clic en Cambiar.
  4. Seleccione el modo de grabación en el cuadro Cambiar modo de grabación.

Recuperar descripciones de campo para campos de solo lectura/deshabilitados

  1. Archivo > Nuevo > Transaction > Crear desde grabación de SAP.
  2. Inicie sesión en SAP (si aún no lo ha hecho).
  3. Recuperar descripciones de campo para campos de solo lectura/deshabilitados.

Título (campo editable)

  1. Archivo > Guardar.
  2. Archivo de script > Título del script.

Comentarios (campo editable)

  1. Archivo > Guardar.
  2. Archivo de script > Comentarios del desarrollador.

Bloquear script de Transaction

  1. Archivo > Guardar.
  2. Archivo de script > Bloquear script.

Mostrar información: versión de Transaction

Archivo > Guardar.> Archivo de script > Versión

Mostrar información: Creado por, Creado el

Archivo > Información

Objetivo de la creación

Pestaña Asignación > Panel de propiedades > Comentarios del desarrollador

Cambiar el código de transacción de una grabación existente Pestaña Asignación > Panel Propiedades

Asignar, Transaction

Funciones Ubicación en Studio 20.3

Asignar automáticamente

Asignar > Asignar automáticamente

Vista básica del asignador

Vista > Vista básica

Vista de experto del asignador

Vista > Vista de experto

Habilitar/deshabilitar fila

Asignador > columna Habilitar

Asignador > clic con el botón secundario en el campo > Habilitar/Deshabilitar

Panel Propiedades > Campo habilitado

Tipo de asignación

Asignador > columna Asignación

Asignador > clic con el botón secundario en el campo > Dirección de la asignación

Panel Propiedades > Dirección de la asignación

Asignar > botón Dirección de la asignación en la cinta

Bucle y Aplicar hoja múltiple

Asignar > Crear bucle

Las columnas Descripción del campo, Nombre de campo, Valores y Notas son editables

Cambiar la descripción/los valores en la propia línea

Cambiar la descripción/los valores desde el panel Propiedades

Añadir comentarios a campos en lugar de notas:

  1. Botón secundario > Insertar comentario
  2. Propiedades > Comentarios del autor

Condición

Asignar > Crear condición

Leer desde SAP

Asignador > columna Asignación > Descargar desde SAP

Asignador > clic con el botón secundario en el campo > Dirección de la asignación > Descargar desde SAP

Panel Propiedades > Dirección de la asignación > Descargar desde SAP

Asignar > botón Dirección de la asignación en la cinta > Descargar desde SAP

Cambiar tipo de origen

Asignador > panel Conjunto de datos

Asignación de columna > Por columnas

  1. Archivo > Nuevo > Transaction > Crear desde grabación de SAP.
  2. Inicie sesión en SAP (si aún no lo ha hecho).
  3. Tipo de datos > Excel.

Asignación de columna > Por celdas

Asignar > grupo Asignación en la cinta > Asignación basada en celda

Validación activada/desactivada

Asignar > Permitir validación

Filtro del asignador (Ocultar todos los campos deshabilitados)

Ver > Campos deshabilitados

Filtro del asignador (Ocultar los campos asignados)

Ver > Campos asignados

Filtro del asignador (Ocultar campos con valor absoluto)

Ver > Valores fijos

Filtro del asignador (Ocultar campos del sistema (campos BDC))

Ver > Campos del sistema

Buscar en el asignador

Asignar > grupo Asignación en la cinta

Deshacer cambio en el asignador

Asignar > Deshacer

Actualizar asignador

Asignar > grupo Asignación en la cinta

Sincronizar/Sincronizar todo

Asignar > grupo Asignación en la cinta

Cortar/Copiar/Pegar filas

Asignar > Cortar/Copiar/Pegar

Haga clic con el botón secundario en una fila y haga clic en Cortar o Copiar; a continuación, haga clic con el botón secundario en una fila y haga clic en Pegar.

Eliminar filas

Asignar > Eliminar

Haga clic con el botón secundario en una fila y haga clic en Eliminar

Bloquear encabezados

Asignar > Bloquear encabezados

Escribir encabezados

Asignar > Escribir encabezados

Restaurar asignación

Asignar > Restaurar asignación

Vistas previas de Excel y de Access

Función

Ubicación en Studio 20.3

Icono

Añadir hoja (Excel)

Panel Conjunto de datos > Añadir hoja

añadir hoja

Abrir (Excel)

Panel Conjunto de datos > Abrir un archivo de datos diferente (botón Abrir carpeta)

examinar

Guardar (Excel)

Panel Conjunto de datos > Guardar el archivo actual de conjunto de datos

botón guardar

Añadir tabla nueva (Access)

Panel Conjunto de datos > Añadir tabla

añadir tabla

Añadir columna nueva (Access)

Panel Conjunto de datos > Añadir columna

añadir columna

Cambiar tabla (Access)

Panel Conjunto de datos > Botón secundario sobre el nombre de la tabla

 

Abrir (Access)

Abrir un archivo de conjunto de datos diferente

examinar

Guardar (Access)

Panel Conjunto de datos > Guardar el archivo actual de conjunto de datos

botón guardar

Documentos adjuntos

Asignar > Funciones avanzadas

Propiedades de Transaction

Las propiedades del script, las pantallas y los campos están en la cinta de pestañas del Asignador y en el panel de propiedades.

Funciones

Ubicación en Studio 20.3

Omitir pantalla si no se encuentra

Asignar > Omitir si no aparece

Asignador > Columna Descripción > icono

Panel Propiedades > Omitir si no aparece

Columna de bucle

Panel Propiedades > Columna de bucle

Omitir transacción si no hay datos

Asignar > Solicitar datos

Asignador > columna Valor > icono

Panel Propiedades > Datos necesarios

Validar por lista

Asignar > Valores permitidos

Asignador > columna Valor > icono

Panel Propiedades > Valores permitidos

Pantalla Ejecutar, Transaction

Funciones

Ubicación en Studio 20.3

Publicar el script de Transaction (en un archivo de Excel)

Ejecutar > grupo de la cinta Acciones del script > Publicar

Ver metadatos del script

Archivo > Información

Añadir un script a Favoritos

Archivo > Abrir > Scripts recientes > Anclar este elemento

Elegir otro archivo de datos desde la pantalla Ejecutar (Examinar)

Ejecutar > Abra otro archivo de datos (abra el botón de la carpeta de la barra de estado amarilla de arriba)

Abrir archivo de datos

Ejecutar > Abra el archivo de datos en Excel (sobre la barra de estado amarilla de arriba)

Escribir encabezados

Ejecutar > Escribir encabezados

Fila inicial, Fila final

Ejecutar

Nombre de la hoja, Número de filas

Ejecutar

Columna de registro, Columna de registro de validación (si la validación está activada)

Asignador > campo Registro de ejecuciones, campo Registro de validación

Motivos de la ejecución

Se abre el cuadro de diálogo al ejecutar cuando se ha seleccionado Solicitar el motivo de la ejecución.

Ejecutar ahora (opciones de ejecución)

Ejecutar > Ejecutar

Ejecutar > Ejecutar rango especificado

Ejecutar > Ejecutar las cinco primeras filas

Ejecutar más tarde (opciones de ejecución)

Ejecutar > Programar

Ejecutar solo errores (opciones de ejecución)

Ejecutar > Ejecutar solo filas de error

Ejecución paso a paso - Detener en todas las pantallas

Ejecutar > Depurar rango especificado

Ejecutar > Depurar solo la primera fila

Ejecución paso a paso - Detener en todos los errores

Ejecutar > Ejecutar y detener en errores

Iniciar GUI

Ejecutar > Iniciar SAP GUI

Validar

Ejecutar > Validar

Estado de progreso de la ejecución en la barra de estado

Barra de progreso de la ejecución bajo la cinta

Detener

Detener (en la barra de progreso de la ejecución bajo la cinta)

Opciones de ejecución avanzadas

Funciones

Ubicación en Studio 20.3

Cerrar la aplicación tras la ejecución

Asignar > panel Propiedades (propiedades del script)

Asignación de la columna de registro o log ampliado

Asignador > campo Log ampliado

Adjuntar sello de tiempo a los mensajes de registro de SAP

Campo de registro > Propiedades > Anexar marca de hora

Indicador de omisión de campo

Ejecutar > Indicador de omisión

Retraso entre las transacciones

Ejecutar > Retardo de carga

Vincular el script de Transaction

Ejecutar > Encadenar scripts

Archivo de inicio de sesión automático

Ejecutar > Credenciales de inicio de sesión automático

Copia de seguridad de datos SAP

Ejecutar > Hacer copia de seguridad de los datos

Ejecución no grabada

Ejecutar > Ejecutar solo filas no procesadas

Opción Guardar en Excel

Archivo > Opciones > Configuración de datos

Visor del registro > Gráfico, Exportar

Archivo > Visor del registro

Programador (vista Básica)

Archivo > Tareas programadas

Programador (posibilidad de programar una ejecución desde el asistente/la página del programador)

Ejecutar > Programar

Comprobación de autorización

Archivo > Cuenta

Query

Nueva consulta

Funciones

Ubicación en Studio 20.3

Icono

Origen de datos: Tablas

Archivo > Nuevo > Consulta > Crear desde tablas

botón crear desde tablas

Origen de datos: InfoSets/Consultas

Archivo > Nuevo > Consulta > Crear desde InfoSet

botón crear desde infoset o consulta

Origen de datos: bases de datos lógicas

Archivo > Nuevo > Consulta > Crear desde bases de datos lógicas

botón crear desde base de datos lógica

Tablas de SAP y constructor de consultas

Funciones

Ubicación en Studio 20.3

Árbol del diccionario de datos con categorías

Área de trabajo > Búsqueda de tabla > Diccionario de datos

Restaurar el diccionario de datos maestros

Haga clic con el botón secundario en el nivel superior del diccionario de datos

Opciones de categoría del diccionario de datos:

Añadir subcategoría

Cambiar nombre de categoría

Eliminar categoría

Añadir tabla a categoría

Sincronizar

Haga clic con el botón secundario en una categoría del diccionario de datos

Opciones de tabla del diccionario de datos:

Añadir tabla de SAP a área de trabajo

Eliminar tabla

Haga clic con el botón secundario en una tabla del diccionario de datos

Diccionario de datos: buscar por tabla

Área de trabajo > Búsqueda de tabla

Añadir tabla

Área de trabajo > Añadir tabla

Eliminar tabla

Área de trabajo > seleccione la tabla > Eliminar tabla

Inspeccionar tabla

Área de trabajo > seleccione la tabla > Inspeccionar tabla

Mostrar en el diccionario de datos

Área de trabajo > seleccione la tabla > Mostrar en el diccionario de datos

Añadir tablas rápidamente

Área de trabajo > cuadro Agregar rápidamente > Añadir al área de trabajo

Opciones de tabla:

Ordenar por descripción de campo

Ordenar por nombre de campo

Ordenar por selección de campo

Ordenación de campos predeterminada

Haga clic con el botón secundario en la tabla del área de trabajo

Opciones de combinación

Área de trabajo > Buscar tabla de unión

Haga clic con el botón secundario en la combinación

Convertir join

Área de trabajo > Convertir combinación

Eliminar join

Área de trabajo > Eliminar combinación

Criterios

Funciones

Ubicación en Studio 20.3

Panel Criterios, Salida

Área de trabajo > tabla > casilla Salida

Panel Criterios, Selección

Área de trabajo > tabla > casilla Criterio

Panel Criterios, Descripción de campo

Área de trabajo > tabla > Descripción de nombre

Panel Criterios, Tipo de selección

Criterios > grupo Criterios en la cinta

Panel Criterios, Cláusula Where

Criterios

Panel Criterios, Necesario

Criterios > grupo Criterios en la cinta > Solicitar datos

Asignar, Query

Funciones

Ubicación en Studio 20.3

Asignar automáticamente

Asignar > Asignar automáticamente

Habilitar/deshabilitar fila

Asignador > columna Habilitar

Asignador > clic con el botón secundario en el campo > Habilitar/Deshabilitar

Panel Propiedades > Campo habilitado

Tipo de asignación

Asignador > columna Asignación

Asignador > clic con el botón secundario en el campo > Dirección de la asignación

Panel Propiedades > Dirección de la asignación

Expresión de Excel

Celda de evaluación de la expresión

Transformar asignación original

Descripción de la evaluación de la expresión

Validar

Asignar > seleccionar campo en el asignador > Añadir transformación

Asignador > icono en la columna Asignado a la columna

Panel Propiedades > icono Transformar fórmula

Vista previa de la ejecución

Asignar > Vista previa de la ejecución

Nota: Solo se reconocen fórmulas con sintaxis en inglés. Se devolverá un error al utilizar hojas de Excel en alemán, francés o español.

Vistas previas de Excel y de Access

Funciones

Ubicación en Studio 20.3

Icono

Abrir (Excel)

Panel Conjunto de datos > Abrir un archivo de datos diferente (botón Abrir carpeta)

examinar

Guardar (Excel)

Panel Conjunto de datos > Guardar el archivo actual de conjunto de datos

botón guardar

Propiedades y opciones de Query

Funciones

Ubicación en Studio 20.3

Cuadro de propiedades del script de Query:

  • Título
  • Sistema SAP
  • Creado por
  • Fecha y hora
  • Motivo de la creación
  • Comentarios

Asignar > Panel Propiedades

Cuadro de propiedades del script de Query:

  • Bloquear el script de Query
  • Contraseña
Archivo > Guardar**

** Para guardar un script en una versión anterior, haga clic en el cuadro Versión y elija la versión que desee.

Pantalla Ejecutar, Query

Funciones

Ubicación en Studio 20.3

Publicar

Ejecutar > Publicar

Escribir encabezados

Ejecutar > Escribir encabezados

Fila inicial

Ejecutar

Nombre de la hoja, Número de filas

Ejecutar

Motivo de la ejecución

Se abre el cuadro de diálogo al ejecutar cuando se ha seleccionado Solicitar el motivo de la ejecución.

Ejecutar ahora

Ejecutar > Ejecutar

Ejecutar > Ejecutar rango especificado

Ejecutar > Ejecutar las cinco primeras filas

Ejecutar más tarde

Ejecutar > Programar

Modo en segundo plano

Ejecutar > Iniciar modo en segundo plano

Ejecutar como proceso en segundo plano de SAP

Ejecutar > Ejecutar como proceso en segundo plano de SAP

Adaptive Query Throttling

Ejecutar > Habilitar Adaptive Query Throttling

N.º de entradas

Ejecutar > Número de entradas

Herramientas/Opciones

Si desea obtener más detalles, consulte Opciones de Studio.

Valores predeterminados de la aplicación

Funciones

Ubicación en Studio 20.3

Valores predeterminados de la ruta de acceso

Archivo > Opciones > Ubicaciones

Valores predeterminados de Microsoft Excel

Archivo > Opciones > Datos

Columna de registro Se puede elegir entre la primera y la última columna o especificar la columna en el asignador.
Utilizar una hoja de cálculo de Excel en la vista previa del asignador Studio 20.3 muestra la hoja de Excel en modo Spreadsheet Gear
Ejecutar Excel en segundo plano Studio 20.3 ejecuta Excel en segundo plano pero no lo lanza

Preferencia de lectura de datos

Archivo > Opciones > Datos

Número de filas que quedarán vacías antes de que la ejecución se detenga

Archivo > Opciones > Datos

Número de registros predeterminado en Recientes y Favoritos

Archivo > Opciones > Configuración de datos

Indicador de omisión de campo

Archivo > Opciones > Datos

Recortar los datos antes de cargarlos en el sistema SAP

Archivo > Opciones > Datos

Número predeterminado de registros para descargar Archivo > Opciones > Datos

Valores predeterminados de SAP

Funciones

Ubicación en Studio 20.3

Valores predeterminados de inicio de sesión

Archivo > Opciones > Configuración de SAP

Valores predeterminados de grabación

Archivo > Opciones > Configuración de SAP

Permitir inicio multiproceso de SAP GUI

Archivo > Opciones > Configuración de SAP

Formatos de los datos de usuario Archivo > Opciones > Datos

Administración de errores

Funciones

Ubicación en Studio 20.3

Para Excel

Común para todos los archivos de datos: Archivo > Opciones > Registros y errores

Para Access

Común para todos los archivos de datos: Archivo > Opciones > Registros y errores

Rastreo (aplicación, SAP)

Archivo > Opciones > Registros y errores

Opciones adicionales

Funciones

Ubicación en Studio 20.3

Administración de ALF

Cuadro de diálogo Inicio de sesión en SAP avanzado

Advertencia del servidor de producción

Archivo > Opciones > Advertencia del servidor de producción

Configuración de conexiones del cliente

Archivo > Opciones > Proxy y correo electrónico

Datos de registro del encabezado

Archivo > Opciones > Registros y errores

Restaurar valores predeterminados

Archivo > Opciones

Funciones y comandos diversos

Funciones

Ubicación en Studio 20.3

Cambio de idioma desde la barra de estado

Archivo > Ayuda > Lista idiomas

Información de conexión del servidor SAP en la barra de estado

Barra de estado

Mensaje de bienvenida al usuario que ha iniciado sesión

Barra de estado

Icono conectado/no conectado en la barra de estado

Nombre del usuario que ha iniciado sesión en la barra de estado