Actualización a Studio - Automate_Studio - 24.0

Guía de instalación y actualización de Automate Studio con Studio Administrator

Product type
Software
Portfolio
Integrate
Product family
Product
Automate > Automate Studio
Version
24.0
Language
Español (España)
Product name
Automate Studio
Title
Guía de instalación y actualización de Automate Studio con Studio Administrator
Copyright
2024
First publish date
2018
ft:lastEdition
2024-05-23
ft:lastPublication
2024-05-23T17:14:30.740617

Hay varias situaciones que pueden llevarle a actualizar los clientes de Studio.

Si ya es cliente de Studio con Connect y desea actualizar, lea la notificación Final de la vida útil de Studio con Connect.

En esta página mostramos la mejor trayectoria que puede seguir para cada uno de los siguientes casos: 

Nota: Estas rutas de acceso se aplican a Studio cuando trabaja con Automate Studio Administrator. Para los casos de Studio con Evolve o Studio con Studio Manager, la diferencia entre las trayectorias estriba en que la versión de Evolve/Studio Manager siempre debe coincidir con la de Studio.

Se supone que seguirá las prácticas habituales de actualización como, por ejemplo, actualizará siempre los entornos de pruebas/desarrollo y pasará a los sistemas de control de calidad y producción para minimizar el impacto de cualquier posible riesgo en la actualización. En los casos en los que no se le pida actualizar AFM desde el inicio, también se recomienda que planifique hacerlo para que pueda disfrutar de todas las ventajas de la nueva versión de Studio.

Actualizar su versión de SAP ERP

Hace referencia a la actualización del sistema base de SAP de la versión A a la B (por ejemplo, actualizar a SAP S/4HANA 1909). Consulte los requisitos del sistema de Studio antes de tomar la decisión para asegurarse de que exista una versión de Studio compatible con la versión específica de SAP.

Prácticas recomendadas

  1. Actualice AFM y Studio simultáneamente a la versión en la que se han hecho pruebas con esta versión de SAP ERP.
  2. Importe sus scripts y haga pruebas de regresión en ellos. Modifíquelos si es necesario.
  3. No tenemos acceso previo al software de SAP S/4HANA, por lo que nuestro proceso de certificación de SAP puede tardar varios meses en completarse desde que SAP haya lanzado su versión de S/4HANA. El tiempo necesario dependerá del alcance de las modificaciones que realicen y de si tenemos que incluir cambios en componentes de terceros en nuestro producto.

    Para obtener más información, consulte la tabla de compatibilidad de ECC y S/4HANA de Automate Function Module.

Opción alternativa

  1. Póngase en contacto con el Servicio de asistencia al clientede Precisely para saber si existen modificaciones conocidas necesarias en Studio o en otros componentes de terceros como resultado de esta versión de SAP ERP. Si no se ha identificado ninguna modificación, compruebe que la versión de AFM cuya compatibilidad haya probado Automate con la versión de SAP aparezca como compatible para su versión existente de Studio o Transaction, Query y Direct.
  2. Si es compatible, actualice AFM a la versión en la que se han hecho pruebas con esta versión de SAP.
  3. Realice las pruebas de regresión de sus scripts existentes en entornos de prueba con esta versión de SAP. Si encuentra errores, actualice a la versión de Studio que coincida con la versión de AFM e importe los scripts anteriores para ver si se resuelven los errores.
  4. Si aún hay errores en sus scripts, modifíquelos para actualizarlos y poder resolver los errores.
  5. Realice las pruebas de regresión necesarias establecidas por su empresa.

Actualizar su versión de SAP GUI

Hace referencia a la actualización de su SAP GUI de la versión A a la B. Siempre hay que tener en cuenta los requisitos del sistema de Studio antes de tomar esta decisión para asegurarse de que haya una versión de Studio que admita esta versión de SAP GUI.

Prácticas recomendadas

  1. Actualice AFM y Studio a la versión en la que se han hecho pruebas con esta versión de SAP GUI.
  2. Importe sus scripts y haga pruebas de regresión en ellos. Modifíquelos si es necesario.

Opción alternativa

  1. Consulte las notas de la versión o póngase en contacto con el Servicio de asistencia al cliente para saber si existen cambios conocidos necesarios en AFM como resultado de la cualificación de Automate de esta versión de SAP GUI. Si no se ha identificado ninguna modificación, compruebe que la versión de Studio cuya compatibilidad haya probado Automate con la versión de SAP GUI, aparezca como compatible para su versión de AFM.
  2. Si es compatible, actualice primero los clientes de Studio a la versión en la que se han hecho pruebas con la versión de SAP GUI.
  3. Realice las pruebas de regresión de sus scripts existentes en entornos de prueba con esta versión de SAP GUI. Si encuentra errores, actualice a la versión de AFM que coincida con su versión de Studio para ver si esto resuelve los errores.
  4. Si aún hay errores en sus scripts, modifique los scripts para actualizarlos y poder resolver los errores.
  5. Realice las pruebas de regresión necesarias establecidas por su empresa.

Actualizar Microsoft Office o el sistema operativo de Microsoft

Hace referencia a la actualización de Office o de las versiones de su sistema operativo, y la instalación actual de Studio no admite esta actualización. Por ejemplo, Automate 10.7 no admite Office 2016.

Prácticas recomendadas

  1. Utilice los requisitos del sistema de Studio para confirmar qué versiones de los productos de Microsoft son compatibles en cada lanzamiento de los productos de Automate. Actualice Studio a la última versión que admita la combinación de Office o la versión del sistema operativo.
  2. Realice las pruebas de regresión de sus scripts existentes en entornos de prueba con esta versión de sistema operativo/Office.
  3. Si encuentra errores, póngase en contacto con el Servicio de asistencia al cliente de Automate o consulte las notas de la versión en caso de que los problemas tengan que ver con AFM. Si hay problemas con una dependencia de AFM, actualice AFM para que coincida con la versión de Studio. Si no, espere a que se le entregue un parche para arreglar el problema.
  4. Realice las pruebas de regresión necesarias establecidas por su empresa.

Actualización basada en la fecha de fin de ciclo de su versión de Studio o en el acceso a las nuevas funcionalidades de Studio

Esta situación de uso hace referencia a la fecha de fin de ciclo que desencadenaría la caducidad del contrato de mantenimiento del cliente, que le da acceso al Servicio de asistencia al cliente de Automate y le da derecho a actualizar a la última versión de Studio sin coste adicional.

Nota:  Si trabaja con 10.x con SAP GUI 7.10 y va a actualizar tanto la versión de Studio como la de Microsoft Office porque ya no son compatibles, debe consultar la sección anterior titulada Actualizar su versión de SAP GUI.

Sin embargo, si trabaja con versiones 10.x en Office 2013 y debe actualizarse a una versión 12.x o 20.x porque la versión anterior de Automate ya no se admite, puede consultar esta sección, ya que no tiene que actualizar Office.

Prácticas recomendadas

  1. Actualice Studio a la última versión GA disponible y admitida en su entorno actual (consulte Requisitos del sistema de Studio). Si el entorno actual no es compatible, consulte las secciones sobre SAP GUI, versión de SAP o prácticas de actualización de Office/sistema operativo.
  2. Realice las pruebas de regresión de sus scripts existentes en entornos de prueba.
  3. Si encuentra errores, póngase en contacto con el Servicio de asistencia al cliente de Automate o consulte las notas de la versión en caso de que los problemas tengan que ver con AFM. Si hay problemas con una dependencia de AFM, actualice AFM para que coincida con la versión de Studio. Si no, espere a que se le entregue un parche para arreglar el problema.
  4. Realice las pruebas de regresión necesarias establecidas por su empresa.