Übersicht über die Studio-Benutzeroberfläche - Automate_Studio - 24.0

Automate Studio mit Studio Administrator-Installations- und Upgrade-Leitfaden

Product type
Software
Portfolio
Integrate
Product family
Product
Automate > Automate Studio
Version
24.0
Language
Deutsch
Product name
Automate Studio
Title
Automate Studio mit Studio Administrator-Installations- und Upgrade-Leitfaden
Copyright
2024
First publish date
2018
ft:lastEdition
2024-05-23
ft:lastPublication
2024-05-23T16:54:30.674370

Hier finden Sie die allgemeinen Befehle, Funktionen und Aufgaben in Transaction und Query sowie die Studio Optionen und wo Sie sie in Studio 20.3 finden.

Verwenden Sie die Suche mit Strg+F, um einen Befehl oder eine Funktion auf dieser Seite schnell zu finden.

  • „Datei“, „Ansicht“, „Zuordnen“ und „Ausführen“ beziehen sich auf die Registerkarten im Menüband oben im Studio Fenster.
  • Query besitzt außerdem die Registerkarten „Arbeitsbereich“ und „Kriterien“.

Datei

Funktionen Speicherort in Studio 20.3

Neu

Datei > Neu

Öffnen

Datei > Öffnen

Skript speichern*

Datei > Speichern

Symbolleiste für den schnellen Zugriff

Speichern unter *

Datei > Speichern

Symbolleiste für den schnellen Zugriff

Beenden

Datei > Beenden

*Klicken Sie das Kästchen Version an und wählen Sie dann die Version, die Sie möchten, um ein Skript in einer vorherigen Version zu speichern.

Hilfe

Funktionen

Speicherort in Studio 20.3

F1-Hilfe

Datei > Hilfe > Studio Hilfe

Supportinformationen generieren

Datei > Hilfe > Supportinformationen

Info

Datei > Hilfe

Nicht verfügbar Datei > Hilfe > Versionshinweise

Transaction

Neue Aufzeichnung

Funktionen Speicherort in Studio 20.3

Eine Aufzeichnung unter Verwendung eines T-Codes erstellen

Datei > Neu > Transaction > Aus Aufzeichnung erstellen

Felder aus einer Direct Vorlage auswählen.

Datei > Neu > Direct > Aus BAPI erstellen

Anmerkung:

Die Optionen im Kästchen „Aufzeichnungsmodus ändern“ können abweichen, abhängig davon, ob das Automate Funktionsmodul installiert ist. Weitere Informationen dazu finden Sie unter Aufzeichnungsmodi.

Funktionen

Speicherort in Studio 20.3

Stapeleingabemodus

  1. Datei > Neu > Transaction > Aus Aufzeichnung erstellen.
  2. Bei SAP anmelden (falls Sie nicht bereits angemeldet sind).
  3. Klicken Sie auf „Ändern“.
  4. Wählen Sie im Kästchen „Aufzeichnungsmodus ändern“ den Aufzeichnungsmodus.

Stapelfreier Eingabemodus (mit SAP-Steuerung)

  1. Datei > Neu > Transaction > Aus Aufzeichnung erstellen.
  2. Bei SAP anmelden (falls Sie nicht bereits angemeldet sind).
  3. Klicken Sie auf „Ändern“.
  4. Wählen Sie im Kästchen „Aufzeichnungsmodus ändern“ den Aufzeichnungsmodus.

Stapelfreier Eingabemodus (ohne SAP-Steuerung)

  1. Datei > Neu > Transaction > Aus Aufzeichnung erstellen.
  2. Bei SAP anmelden (falls Sie nicht bereits angemeldet sind).
  3. Klicken Sie auf „Ändern“.
  4. Wählen Sie im Kästchen „Aufzeichnungsmodus ändern“ den Aufzeichnungsmodus.

GUI-Scripting

  1. Datei > Neu > Transaction > Aus Aufzeichnung erstellen.
  2. Bei SAP anmelden (falls Sie nicht bereits angemeldet sind).
  3. Klicken Sie auf „Ändern“.
  4. Wählen Sie im Kästchen „Aufzeichnungsmodus ändern“ den Aufzeichnungsmodus.

Automate Funktionsmodul

  1. Datei > Neu > Transaction > Aus Aufzeichnung erstellen.
  2. Bei SAP anmelden (falls Sie nicht bereits angemeldet sind).
  3. Klicken Sie auf „Ändern“.
  4. Wählen Sie im Kästchen „Aufzeichnungsmodus ändern“ den Aufzeichnungsmodus.

Feldbeschreibungen für schreibgeschützte/deaktivierte Felder abrufen

  1. Datei > Neu > Transaction > Aus Aufzeichnung erstellen.
  2. Bei SAP anmelden (falls Sie nicht bereits angemeldet sind).
  3. Feldbeschreibung für schreibgeschützte/deaktivierte Felder abrufen.

Titel (bearbeitbares Feld)

  1. Datei > Speichern.
  2. Skriptfeld > Skripttitel.

Kommentare (bearbeitbares Feld)

  1. Datei > Speichern.
  2. Skriptfeld > Kommentare des Entwicklern.

Transaction Skript sperren

  1. Datei > Speichern.
  2. Skriptdatei > Skript sperren.

Info anzeigen: Transaction Version

Datei > Speichern > Skriptdatei > Version

Info anzeigen: Erstellt von, Erstellt am

Datei > Info

Erstellungszweck

Registerkarte „Zuordnen“ > Bereich „Eigenschaften“ > Entwicklerkommentare

T-Code von vorhandenen Aufzeichnungen ändern Zuordnen Registerkarte > Eigenschaftenbereich

Zuordnen, Transaction

Funktionen Speicherort in Studio 20.3

Automatische Zuordnung

Zuordnen > Automatisches Zuordnen

Grundansicht des Mappers

Ansicht > Grundansicht

Expertenansicht des Mappers

Ansicht > Expertenansicht

Zeile aktivieren/Zeile deaktivieren

Mapper > Spalte aktivieren

Mapper > Rechtsklick Feld > Aktivieren/Deaktivieren

Eigenschaftenbereich > Feld aktiviert

Zuordnungstyp

Mapper > Zuordnung aktivieren

Mapper > Rechtsklick Feld > Zuordnungsrichtung

Eigenschaftenbereich > Zuordnungsrichtung

Zuordnen > Schaltfläche „Zuordnungsrichtung“ im Menüband

Schleife + mehrere Blätter anwenden

Zuordnen > Schleife erstellen

Feldbeschreibung, Feldname, Werte, Hinweisspalten sind bearbeitbar

Beschreibung/Werte in Zeile ändern

Beschreibung/Werte aus dem Eigenschaftenbereich ändern

Kommentare statt Hinweise zu den Feldern hinzufügen:

  1. Rechtsklick > Kommentar einfügen
  2. Eigenschaften > Kommentare des Autors

Bedingung

Zuordnen > Bedingung erstellen

Aus SAP lesen

Mapper > Zuordnungsspalte > Aus SAP herunterladen

Mapper > Rechtsklick Feld > Zuordnungsrichtung > Aus SAP herunterladen

Eigenschaftsbereich > Zuordnungsrichtung > Aus SAP herunterladen

Zuordnen > Schaltfläche „Zuordnungsrichtung“ im Menüband > Aus SAP herunterladen

Quelltyp ändern

Mapper > Datensatzbereich

Spaltenzuordnung > Spaltenbasiert

  1. Datei > Neu > Transaction > Aus Aufzeichnung erstellen.
  2. Bei SAP anmelden (falls Sie nicht bereits angemeldet sind).
  3. Datentyp > Excel.

Spaltenzuordnung > Zellenbasiert

Zuordnen > Zuordnungsgruppe im Menüband > Zellenbasierte Zuordnung

Validierung aus/ein

Zuordnen > Validierung erlauben

Mapper-Filter (Alle deaktivierten Felder ausblenden)

Ansicht > Deaktivierte Felder

Mapper-Filter (Zugeordnete Felder ausblenden)

Ansicht > Zugeordnete Felder

Mapper-Filter (Felder mit absolutem Wert ausblenden)

Ansicht > Festwerte

Mapper-Filter (Systemfelder ausblenden (BDC-Felder))

Ansicht > Systemfelder

In Mapper finden

Zuordnen > Zuordnungsgruppe im Menüband

Änderungen im Mapper rückgängig machen

Zuordnen > Rückgängig machen

Mapper aktualisieren

Zuordnen > Zuordnungsgruppe im Menüband

Syncronisieren/ Alle syncronisieren

Zuordnen > Zuordnungsgruppe im Menüband

Ausschneiden/Kopieren/Einfügen von Zeilen

Zuordnen > Ausschneiden/Kopieren/Einfügen

Klicken Sie mit der rechten Maustaste auf eine Zeile und klicken Sie auf „Ausschneiden“ oder „Kopieren“, und klicken Sie danach mit der rechten Maustaste auf eine Zeile und klicken Sie auf „Einfügen“.

Zeilen löschen

Zuordnen > Löschen

Klicken Sie mit der rechten Maustaste auf eine Zeile und klicken Sie dann auf „Löschen“

Kopfzeilen sperren

Zuordnen > Kopfzeilen sperren

Kopfzeilen schreiben

Zuordnen > Kopfzeilen schreiben

Zuordnung zurücksetzen

Zuordnen > Zuordnung wiederherstellen

Excel-Vorschau, Access-Vorschau

Funktion

Speicherort in Studio 20.3

Symbol

Blatt hinzufügen (Excel)

Datensatzbereich > Blatt hinzufügen

Blatt hinzufügen

Öffnen (Excel)

Datensatzbereich > Eine andere Datendatei öffnen (Schaltfläche „Ordner öffnen“)

Durchsuchen

Speichern (Excel)

Datensatzbereich > Aktuelle Datensatzdatei speichern

Schaltfläche „Speichern“

Fügt neue Tabelle hinzu (Access)

Datensatzbereich > Tabelle hinzufügen

Tabelle hinzufügen

Fügt neue Spalte hinzu (Access)

Datensatzbereich > Spalte hinzufügen

Spalte hinzufügen

Tabelle ändern (Access)

Datensatzbereich > Auf den Tabellennamen klicken

 

Öffnen (Access)

Eine andere Datensatzdatei öffnen

Durchsuchen

Speichern (Access)

Datensatzbereich > Aktuelle Datensatzdatei speichern

Schaltfläche „Speichern“

Dokumentenanhang

Zuordnen > Erweiterte Funktionen

Eigenschaften Transaction

Eigenschaften für das Skript, Bildschirme und Felder befinden sich auf der Registerkarte „Zuordnen“ im Menüband und im Eigenschaftenbereich.

Funktionen

Speicherort in Studio 20.3

Bildschirm überspringen, falls nicht gefunden

Zuordnen > Überspringen, falls nicht vorhanden

Mapper > Beschreibungsspalte > Symbol

Eigenschaftenbereich > Überspringen, falls nicht vorhanden

Schleifenspalte

Eigenschaftenbereich > Schleifenspalte

Falls leer, Transaktion überspringen

Zuordnen > Daten anfordern

Mapper > Wertspalte > Symbol

Eigenschaftenbereich > Daten erforderlich

Nach Liste validieren

Zuordnen > Erlaubte Werte

Mapper > Wertspalte > Symbol

Eigenschaftenbereich > Erlaubte Werte

Ausführungsbildschirm, Transaction

Funktionen

Speicherort in Studio 20.3

Transaction Skript veröffentlichen (an eine Excel-Datei)

Ausführen > Skriptaktionengruppe im Menüband ausführen > Veröffentlichen

Skriptmetadaten anzeigen

Datei > Info

Skript zu Favoriten hinzufügen

Datei > Öffnen > Zuletzt verwendete Skripte > Dieses Objekt verankern

Wählen Sie eine andere Datendatei aus dem Ausführungsbildschirm (Durchsuchen)

Ausführen > Eine andere Datendatei öffnen (Schaltfläche „Ordner öffnen“ über der gelben Statusleiste)

Datendatei öffnen

Ausführen > Datendatei in Excel öffnen (über der gelben Statusleiste)

Kopfzeilen schreiben

Ausführen > Kopfzeilen schreiben

Startzeile, Endzeile

Ausführen

Blattname, Anzahl der Zeilen

Ausführen

Protokollspalte, Validierungsprotokollspalte (falls Validierung aktiviert ist)

Mapper > Protokoll ausführen, Validierungsprotokoll

Ausführungsgründe

Dialogfeld öffnet sich beim Ausführen, wenn „Ausführungsgrund erforderlich machen“ ausgewählt wurde.

Jetzt ausführen (Ausführungsoptionen)

Ausführen > Ausführen

Ausführen > Angegebenen Bereich ausführen

Ausführen > Erste 5 Zeilen ausführen

Später ausführen (Ausführungsoptionen)

Ausführen > Planen

Bei Fehlern ausführen (Ausführungsoptionen)

Ausführen > Nur Zeilen mit Fehlern ausführen

Schrittweises Ausführen - Auf allen Bildschirmen stoppen

Ausführen > Angegebenen Bereich debuggen

Ausführen > Nur erste Zeile debuggen

Schrittweises Ausführen - Bei Fehlern stoppen

Ausführen > Ausführen und bei Fehlern anhalten

GUI starten

Ausführen > SAP-GUI starten

Validieren

Ausführen > Validieren

Ausführungsfortschritt in der Statusleiste

Fortschrittsleiste unterhalb des Menübands ausführen

Stoppen

Fortschrittsleiste unterhalb des Menübands ausführen

Erweiterte Ausführungsoptionen

Funktionen

Speicherort in Studio 20.3

Anwendung nach Ausführung schließen

Zuordnen > Eigenschaftenbereich (Skripteigenschaften)

Erweiterte Protokollspaltenzuweisung

Mapper > Erweitertes Protokollfeld

Zeitstempel an die SAP-Protokollnachricht anhängen

Protokollfeld > Eigenschaften > Zeitstempel anhängen

Indikator zum Überspringen von Feldern

Ausführen > Indikator zum Überspringen

Verzögerung zwischen Transaktionen

Ausführen > Verzögerung des Uploads

Transaction Skript verknüpfen

Ausführen > Skripte verketten

Automatische Anmeldedatei

Ausführen > Anmeldedaten für automatische Anmeldung

Sicherungskopie von SAP-Daten erstellen

Ausführen > Sicherungskopie von Daten erstellen

Nicht veröffentlichte ausführen

Ausführen > Nur nicht verarbeitete Zeilen ausführen

Option für das Speichern in Excel

Datei > Optionen > Dateneinstellungen

Protokollanzeige > Diagramm, Exportieren

Datei > Protokollanzeige

Planer (Grundansicht)

Datei > Geplante Aufgaben

Planer (Möglichkeit, eine Ausführung durch den Planerassistenten/die Planerseite zu planen)

Ausführen > Planen

Berechtigungsprüfung

Datei > Konto

Abfrage

Neue Abfrage

Funktionen

Speicherort in Studio 20.3

Symbol

Datenquelle: Tabellen

Datei > Neu > Query > Aus Tabellen erstellen

Von Tabellenschaltfläche erzeugen

Datenquelle: InfoSets/Abfragen

Datei > Neu > Query > Aus InfoSet erstellen

Von InfoSet- oder Abfrageschaltfläche erzeugen

Datenquelle: Logische Datenbanken

Datei > Neu > Query > Aus logischer Datenbank erstellen

Von logischer Datenbankschaltfläche erzeugen

SAP-Tabellen und Abfragenersteller

Funktionen

Speicherort in Studio 20.3

Datenwörterbuchbaum mit Kategorien

Arbeitsbereich > Tabellensuche > Datenwörterbuch

Stammdatenwörterbuch wiederherstellen

Mit der rechten Maustaste auf die oberste Ebene des Datenwörterbuchs klicken

Datenwörterbuch-Kategorieoptionen:

Unterkategorie hinzufügen

Kategorie umbenennen

Kategorie löschen

Tabelle zu Kategorie hinzufügen

Synchronisieren

Mit der rechten Maustaste auf eine Datenwörterbuchkategorie klicken

Datenwörterbuch-Tabellenoptionen:

SAP-Tabelle zum Arbeitsbereich hinzufügen

Tabelle entfernen

Mit der rechten Maustaste auf eine Datenwörterbuchtabelle klicken

Datenwörterbuch: Nach Tabelle durchsuchen

Arbeitsbereich > Tabellensuche

Tabelle hinzufügen

Arbeitsbereich > Tabelle hinzufügen

Tabelle entfernen

Arbeitsbereich > Tabelle auswählen > Tabelle entfernen

Tabelle überprüfen

Arbeitsbereich > Tabelle auswählen > Tabelle überprüfen

In Datenwörterbuch anzeigen

Arbeitsbereich > Tabelle auswählen > In Datenwörterbuch anzeigen

Tabellen schnell hinzufügen

Arbeitsbereich > Kästchen „Schnell hinzufügen“ > Zu Arbeitsbereich hinzufügen

Tabellenoptionen:

Nach Feldbeschreibung sortieren

Nach Feldname sortieren

Nach Feldauswahl sortieren

Standardmäßige Feldsortierung

Mit der rechten Maustaste auf die Tabelle im Arbeitsbereich klicken

Joinoptionen

Arbeitsbereich > Verbindende Tabelle suchen

Mit der rechten Maustaste auf das Join klicken

Join umwandeln

Arbeitsbereich > Join umwandeln

Join entfernen

Arbeitsbereich > Join entfernen

Kriterien

Funktionen

Speicherort in Studio 20.3

Kriterienbereich, Ausgabe

Arbeitsbereich > Tabelle > Ausgabekontrollkästchen

Kriterienbereich > Auswahl

Arbeitsbereich > Tabelle > Kriterienkontrollkästchen

Kriterienbereich , Feldbeschreibung

Arbeitsbereich > Tabelle > Namensbeschreibung

Kriterienbereich, Auswahltyp

Kriterien > Kriteriengruppe im Menüband

Kriterienbereich, WHERE-Klausel

Kriterien

Kriterienbereich, Angefordert

Kriterien > Kriteriengruppe im Menüband > Daten anfordern

Zuordnen, Query

Funktionen

Speicherort in Studio 20.3

Automatische Zuordnung

Zuordnen > Automatisches Zuordnen

Zeile aktivieren/Zeile deaktivieren

Mapper > Spalte aktivieren

Mapper > Rechtsklick auf das Feld > Aktivieren/Deaktivieren

Eigenschaftenbereich > Feld aktiviert

Zuordnungstyp

Mapper > Zuordnung aktivieren

Mapper > Rechtsklick Feld > Zuordnungsrichtung

Eigenschaftenbereich > Zuordnungsrichtung

Excel-Ausdruck

Ausdruckauswertungszelle

Ursprüngliche Zuordnung transformieren

Ausdruckauswertungsbeschreibung

Validieren

Zuordnen > Feld in Mapper auswählen > Transformation hinzufügen

Mapper > Symbol in der Spalte „Spalte zugeordnet“

Eigenschaftenbereich > Transformationsformel-Symbol

Vorschau der Ausführung erstellen

Zuordnen > Vorschau der Ausführung erstellen

Anmerkung: Es werden nur Formeln in englischer Syntax erkannt; wenn sie in einem Excel-Arbeitsblatt für Deutsch, Französisch oder Spanisch verwendet werden, wird ein Fehler zurückgegeben.

Excel-Vorschau, Access-Vorschau

Funktionen

Speicherort in Studio 20.3

Symbol

Öffnen (Excel)

Datensatzbereich > Eine andere Datendatei öffnen (Schaltfläche „Ordner öffnen“)

Durchsuchen

Speichern (Excel)

Datensatzbereich > Aktuelle Datensatzdatei speichern

Schaltfläche „Speichern“

Query Eigenschaften und Optionen

Funktionen

Speicherort in Studio 20.3

QUERY Skript-Eigenschaftenkästchen:

  • Titel
  • SAP-System
  • Erstellt von
  • Datum und Uhrzeit
  • Erstellungsgrund
  • Kommentare

Zuordnen > Eigenschaftenbereich

QUERY Skript-Eigenschaftenkästchen:

  • QUERY Skript sperren
  • Kennwort
Datei > Speichern**

*„Klicken Sie auf das Kästchen Version, und wählen Sie dann die gewünschte Version aus, um ein Skript in einer vorherigen Version zu speichern.

Ausführungsbildschirm, Query

Funktionen

Speicherort in Studio 20.3

Veröffentlichen

Ausführen > Veröffentlichen

Kopfzeilen schreiben

Ausführen > Kopfzeilen schreiben

Startzeile

Ausführen

Blattname, Anzahl der Zeilen

Ausführen

Ausführungsgrund

Dialogfeld öffnet sich beim Ausführen, wenn „Ausführungsgrund erforderlich machen“ ausgewählt wurde.

Jetzt ausführen

Ausführen > Ausführen

Ausführen > Angegebenen Bereich ausführen

Ausführen > Erste 5 Zeilen ausführen

Später ausführen

Ausführen > Planen

Hintergrundmodus

Ausführen > Hintergrundmodus ausführen

Als SAP-Hintergrundprozess ausführen

Ausführen > Als SAP-Hintergrundprozess ausführen

Adaptive Query-Drosselung

Ausführen > Adaptive Query Throttling aktivieren

Anzahl der Einträge

Ausführen > Anzahl der Einträge

Extras > Optionen

Für weitere Details siehe Studio Optionen.

Standardeinstellungen für Anwendungen

Funktionen

Speicherort in Studio 20.3

Standardpfad

Datei > Optionen > Speicherorte

Standardeinstellungen für Microsoft Excel

Datei > Optionen > Daten

Protokollspalte Kann zwischen der ersten und der letzten Spalte wählen oder die Spalte im Mapper angeben.
Verwendenden des Excel-Spreadsheets in der Mapper-Vorschau Studio 20.3 zeigt das Excel-Arbeitsblatt im Modus SpreadsheetGear an.
Excel im Hintergrundmodus ausführen Studio 20.3 führt Excel im Hintergrund aus, ohne Excel zu starten.

Datenlese-Einstellung

Datei > Optionen > Daten

Anzahl der Zeilen, die leer sein müssen, bevor die Ausführung gestoppt wird:

Datei > Optionen > Daten

Standardanzahl der Datensätze in zuletzt geöffneten Dateien und Favoriten:

Datei > Optionen > Dateneinstellungen

Indikator zum Überspringen von Feldern

Datei > Optionen > Daten

Daten vor dem Hochladen in das SAP-System kürzen

Datei > Optionen > Daten

Standardmäßige Anzahl der herunterzuladenden Datensätze Datei > Optionen > Daten

SAP-Standardwerte

Funktionen

Speicherort in Studio 20.3

Standardwerte für die Anmeldung

Datei > Optionen > SAP-Einstellungen

Aufzeichnen von Standardwerten

Datei > Optionen > SAP-Einstellungen

SAP-GUI-Start mit Multithreading erlauben

Datei > Optionen > SAP-Einstellungen

Benutzerdatenformate Datei > Optionen > Daten

Fehlerverwaltung

Funktionen

Speicherort in Studio 20.3

Für Excel

Häufig für alle Datendateien: Datei > Optionen > Protokolle und Fehler

Für Access

Häufig für alle Datendateien: Datei > Optionen > Protokolle und Fehler

Rückverfolgung (Anwendung, SAP)

Datei > Optionen > Protokolle und Fehler

Weitere Optionen

Funktionen

Speicherort in Studio 20.3

ALF-Verwaltung

Erweitertes SAP-Anmeldedialogfeld

Produktionsserverwarnung

Datei > Optionen > Produktionsserverwarnung

Client-Verbindungseinstellungen

Datei > Optionen > Proxy und E-Mail

Kopfprotokolldetails

Datei > Optionen > Protokolle und Fehler

Standardeinstellungen wiederherstellen

Datei > Optionen

Verschiedene Befehle und Funktionen

Funktionen

Speicherort in Studio 20.3

Sprache in der Statusleiste ändern

Datei> Hilfe>Sprach List

SAP-Serververbindungsinformationen in der Statusleiste

Statusleiste

Willkommensmessage für angemeldete Benutzer

Statusleiste

Online-/Offlinesymbol in der Statusleiste

Name des angemeldeten Benutzers in der Statusleiste