Where is it in Studio 20.3 - Automate_Studio - 20.3

Automate Studio with Connect User Guide

Product type
Software
Portfolio
Integrate
Product family
Automate
Product
Automate > Automate Studio
Version
20.3
Language
English
Product name
Automate Studio
Title
Automate Studio with Connect User Guide
Topic type
Administration
Installation
Overview
How Do I
First publish date
2018
ft:lastEdition
2024-05-06
ft:lastPublication
2024-05-06T08:28:10.436135

Here are the common commands, features, and tasks in Transaction and Query, as well as Studio Options and where you can find them in Studio 20.3.

To find a command or a feature on this page quickly, press Ctrl+F to search for it.

  • File, View, Map, and Run refer to the ribbon tabs at the top of the Studio window.
  • Query also has Workspace and Criteria tabs.

Home screen

File

Functions Studio 20.3 location

New

File > New

Open

File > Open

Save script*

File > Save

Quick Access Toolbar

Save As*

File > Save

Quick Access Toolbar

Exit

File > Exit

*To save a script as a previous version, click the Version box, and then choose the version that you want.

Help

Functions

Studio 20.3 location

F1 Help

File > Help > Studio Help

Generate support information

File > Help > Support Information

About

File > Help

Not available File > Help > Release Notes

Transaction

New recording

Functions Studio 20.3 location

Create a recording using a t-code

File > New > Transaction > Create from Recording

Select fields from a Direct template

File > New > Direct > Create from BAPI

Recording properties

starting a recording

Note:

The options in the Change Recording Mode box vary, depending on whether Automate Function Module is installed. For more information, see Recording modes.

Functions

Studio 20.3 location

Batch Input Mode

  1. File > New > Transaction > Create from Recording.
  2. Log on to SAP (if not already logged on).
  3. Click Change.
  4. Select the recording mode in the Change Recording Mode box.

Non-Batch Input Mode (With SAP Controls)

  1. File > New > Transaction > Create from Recording.
  2. Log on to SAP (if not already logged on).
  3. Click Change.
  4. Select recording mode from the Change Recording Mode box.

Non-Batch Input mode (Without SAP Controls)

  1. File > New > Transaction > Create from Recording.
  2. Log on to SAP (if not already logged on).
  3. Click Change.
  4. Select recording mode from the Change Recording Mode box.

GUI Scripting

  1. File > New > Transaction > Create from Recording.
  2. Logon to SAP (if not already logged on).
  3. Click Change.
  4. Select recording mode from the Change Recording Mode box.

Automate Function Module

  1. File > New > Transaction > Create from Recording.
  2. Log on to SAP (if not already logged on).
  3. Click Change.
  4. Select recording mode from the Change Recording Mode box.

Retrieve field descriptions for Read only/Disabled fields

  1. File > New > Transaction > Create from Recording.
  2. Log on to SAP (if not already logged on).
  3. Retrieve field description for read only/disabled fields.

Title (editable field)

  1. File > Save.
  2. Script file > Script title.

Comments (editable field)

  1. File > Save.
  2. Script file > Developer comments.

Lock Transaction script

  1. File > Save.
  2. Script file > Lock script.

Display Info: Transaction Version

File > Save > Script file > Version

Display Info: Created By, Created On

File > Info

Purpose of creation

Map tab > Properties panel > Developer comments.

Change t-code of existing recording Map tab > Properties panel

Map, Transaction

Functions Studio 20.3 location

Auto Map

Map > Auto Map

Basic view of the Mapper

View > Basic View

Expert view of the Mapper

View > Expert View

Enable Row/Disable Row

Mapper > Enable column

Mapper > Right-click field > Enable/Disable

Properties panel > Field Enabled

Mapping Type

Mapper > Mapping column

Mapper > Right-click field > Map direction

Properties panel > Map direction

Map > Map direction button on the ribbon

Loop + Apply Multi Sheet

Map > Create Loop

Field Description, Field Name, Values, Notes columns are editable

Change description/values inline

Change description/values from the Properties panel

Add comments to fields instead of notes:

  1. Right-click > Insert Comment
  2. Properties > Author comments

Condition

Map > Create Condition

Read from SAP

Mapper > Mapping column > Download from SAP

Mapper > Right-click field > Map direction > Download from SAP

Properties panel > Map direction > Download from SAP

Map > Map direction button on the ribbon > Download from SAP

Change Source Type

Mapper > Data Set panel

Column Mapping > Column Based

  1. File > New > Transaction > Create from Recording.
  2. Log on to SAP (if not already logged on).
  3. Data type > Excel.

Column Mapping > Cell Based

Map > Mapping group in the ribbon> Cell Based Mapping

Validation Off/On

Map > Allow Validation

Mapper filter (Hide all disabled fields)

View > Disabled Fields

Mapper filter (Hide mapped fields)

View > Mapped fields

Mapper filter (Hide absolute value fields)

View > Fixed Values

Mapper filter (Hide System fields (BDC fields))

View > System Fields

Find in Mapper

Map > Mapping group in the ribbon

Undo Mapper Change

Map > Undo

Refresh Mapper

Map > Mapping group in the ribbon

Synchronize/Synchronize All

Map > Mapping group in the ribbon

Cut/Copy/Paste Rows

Map > Cut/Copy/Paste

Right-click a row and click Cut or Copy, then right-click a row and click Paste.

Delete Rows

Map > Delete

Right-click a row and click Delete

Lock Headers

Map > Lock Headers

Write Headers

Map > Write Headers

Restore Mapping

Map > Restore Mapping

Excel preview, Access preview

Function

Studio 20.3 location

Icon

Add Sheet (Excel)

Data Set panel > Add sheet

add sheet

Open (Excel)

Data Set panel > Open a different data file (open folder button)

browse

Save (Excel)

Data Set panel > Save the current Data Set file

save button

Adds new table (Access)

Data Set panel > Add Table

add table

Adds new column (Access)

Data Set panel > Add Column

add column

Change Table (Access)

Data Set panel > Click the table name

 

Open (Access)

Open a different Data Set file

browse

Save (Access)

Data Set panel > Save the current Data Set file

save button

Document attachment

Map > Advanced Features

Transaction properties

Properties for the script, screens and fields are on the Map tab ribbon and in the Properties panel.

Functions

Studio 20.3 location

Skip Screen If Not Found

Map > Skip If Not Present

Mapper > Description column > icon

Properties panel > Skip If Not Present

Loop Column

Properties panel > Loop Column

Skip Transaction If Empty

Map > Require Data

Mapper > Value column > icon

Properties panel > Data required

Validate by List

Map > Allowed Values

Mapper > Value column > icon

Properties panel > Allowed Values

Run screen, Transaction

Functions

Studio 20.3 location

Publish Transaction script (to an Excel file)

Run > Script Actions group in the ribbon> Publish

View script metadata

File > Info

Add script to favorites

File > Open > Recent scripts > Pin this item

Choose a different data file from the Run screen (Browse)

Run > Open a different data file (open folder button above the yellow status bar)

Open Data File

Run > Open the data file in Excel (above the yellow status bar)

Write Headers

Run > Write Headers

Start Row, End Row

Run

Sheet Name, Number of Rows

Run

Log Column, Validation Log Column (if Validation is turned on)

Mapper > Run Log field, Validate Log field

Run Reasons

Dialog box opens on Run when Require Run Reason is selected.

Run Now (Run options)

Run > Run

Run > Run Specified Range

Run > Run First 5 Rows

Run Later (Run options)

Run > Schedule

Run on Errors (Run options)

Run > Run Only Error Rows

Step-by-Step Run - Stop on all Screens

Run > Debug Specified Range

Run > Debug First Row Only

Step-by-Step Run - Stop on Errors

Run > Run and Stop on Errors

Launch GUI

Run > Start SAP GUI

Validate

Run > Validate

Run progress status in the status bar

Run progress bar below the ribbon

Stop

Stop (in the Run progress bar below the ribbon)

Advanced Run options

Functions

Studio 20.3 location

Close application after running

Map > Properties panel (Script properties)

Extended log column assignment

Mapper > Extended Log field

Append TimeStamp to SAP log messages

Log field > Properties > Append Time Stamp

Skip Field Indicator

Run > Skip Indicator

Delay between transactions

Run > Upload Delay

Link Transaction script

Run > Chain Scripts

Auto Logon File

Run > Auto Logon Credentials

Backup SAP data

Run > Backup Data

Run Not Posted

Run > Run Only Unprocessed Rows

Excel Save option

File > Options > Data Settings

Log Viewer > Chart, Export

File > Log Viewer

Scheduler (Basic view)

File > Scheduled Tasks

Scheduler (Ability to schedule a run from the scheduler wizard/page)

Run > Schedule

Authorization Check

File > Account

Query

New query

Functions

Studio 20.3 location

Icon

Data Source: Tables

File > New > Query > Create from Tables

create from tables button

Data Source: InfoSets/Queries

File > New > Query > Create from InfoSet

create from infoset or query button

Data Source: Logical Databases

File > New > Query > Create from Logical Database

create from logical database button

SAP Tables and Query Builder

Functions

Studio 20.3 location

Data Dictionary tree with categories

Workspace > Table Search > Data Dictionary

Restore Master Data Dictionary

Right-click the top level of the Data Dictionary

Data Dictionary category options:

Add Sub Category

Rename Category

Delete Category

Add Table to Category

Synchronize

Right-click a Data Dictionary category

Data Dictionary table options:

Add SAP Table to Workspace

Remove Table

Right-click a Data Dictionary table

Data Dictionary: Search by Table

Workspace > Table Search

Add Table

Workspace > Add Table

Remove Table

Workspace > select the table > Remove Table

Inspect Table

Workspace > select the table > Inspect Table

Show in Data Dictionary

Workspace > select the table > Show in Data Dictionary

Quick Add tables

Workspace > Quick Add box > Add to Workspace

Table options:

Sort by Field Description

Sort by Field Name

Sort by Field Selection

Default Field Sorting

Right-click the table in the workspace

Join options

Workspace > Find Joining Table

Right-click the join

Convert Join

Workspace > Convert Join

Remove Join

Workspace > Remove Join

Criteria

Functions

Studio 20.3 location

Criteria pane, Output

Workspace > table > Output check box

Criteria pane, Selection

Workspace > table > Criteria check box

Criteria pane, Field Description

Workspace > table > Name Description

Criteria pane, Selection Type

Criteria > Criteria group in the ribbon

Criteria pane, Where Clause

Criteria

Criteria pane, Required

Criteria > Criteria group in the ribbon > Require Data

Map, Query

Functions

Studio 20.3 location

Auto Map

Map > Auto Map

Enable Row/Disable Row

Mapper > Enable column

Mapper > Right-click the field > Enable/Disable

Properties panel > Field Enabled

Mapping Type

Mapper > Mapping column

Mapper > Right-click field > Map direction

Properties panel > Map direction

Excel Expression

Expression Evaluation cell

Transform Original Mapping

Expression Evaluation Description

Validate

Map > select field in the Mapper > Add Transform

Mapper > icon in the Mapped to Column column

Properties panel > Transform formula icon

Preview Run

Map > Preview Run

Note: Only English syntax formulas are recognized; when used in an Excel sheet for German, French, or Spanish, an error is returned.

Excel preview, Access preview

Functions

Studio 20.3 location

Icon

Open (Excel)

Data Set panel > Open a different data file (open folder button)

browse

Save (Excel)

Data Set panel > Save the current Data Set file

save button

Query properties and options

Functions

Studio 20.3 location

QUERY Script Properties box:

  • Title
  • SAP system
  • Created by
  • Date & Time
  • Reason for creation
  • Comments

Map > Properties panel

QUERY Script Properties box:

  • Lock QUERY script
  • Password
File > Save**

**To save a script as a previous version, click the Version box, and choose the version that you want.

Run screen, Query

Functions

Studio 20.3 location

Publish

Run > Publish

Write Headers

Run > Write Headers

Start Row

Run

Sheet Name, Number of Rows

Run

Run reason

Dialog box opens on Run when Require Run Reason is selected.

Run Now

Run > Run

Run > Run Specified Range

Run > Run First 5 Rows

Run Later

Run > Schedule

Background Mode

Run > Start Background Mode

Run as SAP Background Process

Run > Run as SAP Background Process

Adaptive Query Throttling

Run > Enable Adaptive Query Throttling

No. of entries

Run > Number of Entries

Tools > Options

For more details, see Studio Options.

Application Defaults

Functions

Studio 20.3 location

Path defaults

File > Options > Locations

Microsoft Excel defaults

File > Options > Data

Log Column Can choose between first column and last column or specify column in the Mapper
Use Excel Spreadsheet in Mapper Preview Studio 20.3 displays the Excel sheet in Spreadsheet Gear mode
Run Excel in the background mode Studio 20.3 runs Excel in the background but does not launch Excel

Data read preference

File > Options > Data

Number of rows to remain empty before run stops

File > Options > Data

Default No. of records in Recent and Favorite

File > Options > Data Settings

Skip Field Indicator

File > Options > Data

Trim data before uploading into your SAP System

File > Options > Data

Default number of records to download File > Options > Data

SAP Defaults

Functions

Studio 20.3 location

Logon defaults

File > Options > SAP Settings

Recording defaults

File > Options > SAP Settings

Allow multithreaded SAP GUI launch

File > Options > SAP Settings

User Data Formats File > Options > Data

Error Management

Functions

Studio 20.3 location

For Excel

Common for all data files: File > Options > Logs & Errors

For Access

Common for all data files: File > Options > Logs & Errors

Trace (Application, SAP)

File > Options > Logs & Errors

Additional options

Functions

Studio 20.3 location

ALF Management

Advanced SAP Logon dialog box

Production Server Warning

File > Options > Production Server Warning

Client Connection Settings

File > Options > Proxy & Email

Header Log Details

File > Options > Logs & Errors

Restore Defaults

File > Options

Miscellaneous commands and features

Functions

Studio 20.3 location

Change language from the status bar

File > Help > Language list

SAP Server Connection information in the status bar

Status bar

Logged-on user's welcome message

Status bar

Online/offline icon in status bar

Logged-on user's name in the status bar