Assure iOptimize software requirements - Assure_DB2_Data_Monitor_(DB2MON) - Assure_Elevated_Authority_Manager_(EAM) - Assure_Encryption - Assure_Monitoring_and_Reporting_(AMR) - Assure_Secure_File_Transfer - Assure_Secure_File_Transfer_ - Assure_Secure_File_Transfer_PGP - Assure_Secure_File_Transfer_with_PGP - Assure_Security_Multi-Factor_Authentication_(MFA) - Assure_System_Access_Manager_(SAM) - Required_for_All_Modules - assure_ioptimize - assure_itera - assure_mimix - 10.0

License Manager for IBM i Products

Product type
Software
Portfolio
Integrate
Product family
Assure
Product
Assure Security > Assure Encryption
Assure Security > Assure DB2 Data Monitor (DB2MON)
Assure MIMIX™ Software
Assure Security > Assure Monitoring and Reporting (AMR)
Assure Security > Assure Elevated Authority Manager (EAM)
Assure Security > Assure Security Multi-Factor Authentication (MFA)
Assure Security > Assure Secure File Transfer with PGP
Assure Security > Assure Secure File Transfer
Assure Security > Required for All Modules
Assure iOptimize
Assure iTERA
Assure Security > Assure System Access Manager (SAM)
Version
10.0
Language
English
Product name
Assure
Title
License Manager for IBM i Products
Copyright
2023
First publish date
1999

iOptimize installs on a single system and must be installed on System ASP 1. It cannot be installed on a User ASP or an IASP.

License Manager level: License Manager is a required utility that is included in the software installation package for multiple Precisely products, including Assure MIMIX, Assure iOptimize, Assure QuickEDD, and Assure Security. The current versions of these products require License Manager version 10.0. Be aware of the following implications to the product software installation process:

  • If License Manager does not yet exist on a system when you install a new instance of this product, the software installation process automatically installs License Manager using the level included in the software installation package.

  • If License Manager already exists on a system on which you are installing a new instance or upgrading an existing instance of this product and the installed level of License Manager is lower than the level included in the software installation package, the product install or upgrade process automatically upgrades License Manager to the level included in the software installation package.

 If License Manager is not present and you need to use the native user interface to install instead of the Installation Wizard, see Installing when License Manager is not yet installed.

Supported iOptimize upgrades: iOptimize products that are installed at 9.0.01.00 or any higher service pack level can be upgraded to version 10.0 as long as these conditions are met:

  • Maintenance is current. Customers not current on maintenance will only be able to re-install the same version, update, and service pack level (V.U.SP) and install fixes for that level. See Displaying details about a license key.

  • Upgrades to version 10.0 require license keys for version 10.0. New installs of version 10.0 can be completed with no license keys present, although a valid license key is required before you can use iOptimize. For information about obtaining license keys, see Working with license keys.

Operating system: The following table identifies the operating environment requirements that must be met in order to install iOptimize version 10.0 for the first time. The system must have this software installed and be current with the recommended PTFs and service packs applied.

Ensure that the Limit Capabilities (LMTCPB) parameter is set to *NO for the user profile used to complete an install or upgrade.

Use the Check IBM PTF (CHKIBMPTF) command to check whether the IBM i PTFs that Precisely recommends are applied on systems on which iOptimize will be installed. See Checking systems for recommended IBM PTFs for details.

Table 1. Software requirements for version 10.0 of iOptimize on System i

Software

Minimum level

IBM i operating system
  • Option 30, QSHELL
  • Option 33, Portable App Solutions Environment

IBM i 7.2

*COMPATIBLE or *INSTALLED

*COMPATIBLE

Java components

iOptimize requires the use of the iOptimize portal application and the Assure Unified Interface, which both require Java.

iOptimize requires Java in order start the IDETSCTL and IDETSJVM jobs that run in the iOptimize subsystem.

 

V7R1: 5761-JV1 *BASE and
  • Option 16 - Java SE 8 32 Bit, (required for product) or
  • Option 17 - Java SE 8 64 Bit (recommended for the Assure Unified Interface)
V7R2, V7R3 or V7R4: 5770-JV1 *BASE and
  • Option 16 - Java SE 8 32 Bit, (required for product) or
  • Option 17 - Java SE 8 64 Bit (recommended)
Note: The STRVSISVR command for the Assure UI server will fail if 64-bit Java is not installed. However, you can specify STRVSISVR JVM(*IBM32) to start the server in a 32-bit Java environment.

Precisely Licensed Program 7VSI001: When iOptimize is installed, the software installation process automatically installs the Precisely licensed program product (LPP) 7VSI001 *BASE and option 6 into library VSI001LIB if they are not already present on the system. If you install the product using its installation wizard, option 13 is also installed.

Assure Unified Interface: There are additional System i software requirements for the Assure iOptimize portal application. For details, see Requirements for the Assure UI server and portal applications.